Fedora 30 and 29 are not booting


Hi All,

I am relatively new to Linux environment. In my Lenovo Ideapad 110, I have installed Fedora 27 using bootable USB. Recently I noticed that Fedora 27 is not supported. Hence decided to upgrade as recommended. My problem started from there.

  1. Upgraded using GUI option where it automatically recommended to upgrade to Fedora 29 under settings → Details → Check for update. Thought it got downloaded and installed but when upgrade over Laptop was showing only Lenovo Logo. Not booting.
  2. Created Fedora 31 bootable USB and tried booting using that. But laptop is not recognizing that bootable usb.
  3. It recognize only Fedora 27 bootable usb alone hence installed fedora 27 again. Using terminal upgraded to Fedora 30. After ~6 hours it upgraded and shown that upgrade is successful. But it again not booted and showing only lenovo.
  4. Created bootable USB with fedora media writer with both Fedora 31 and Ubuntu 18.04 still USB booting not getting recognized except my Fedora 27 USB alone.

If any one could help that will be really good. Thanks well in advance.

Try burning Fedora 31 ISO unto a DVD … I trust you have a DVD reader in the machine. If USB is failing, DVD mostly works (slower though).

1 Like

Generally when upgrading it is recommended to increment single version. Try doing 27 -> 28. then 28 -> 29. the 29 -> 30.

1 Like

Thanks for the reply. Unfortunately DVD is not working in that laptop.

Thank you for the suggestion. I will try that. My question is that why it’s not recognizing any other USB’s other than Fedora 27 bootable USB alone.

I noticed that in my Lenovo IdeaPad 110 AMD A8 laptop fast boot is enabled in Bios. By any chance can that be the reason for why none of the bootable USBs except Fedora 27 is working. When I got this laptop first OS I installed was Fedora 27. My question is it safe to disable Fast boot in Bios? If I disable will it be possible to enable it later? Kindly clarify. Also please let me know the correct step to disable and enable it.

I found this article about fast boot, as far as I understand, it is about making your computer boot faster, so it looks like it is safe to disable to me. In the article, it says that you can’t boot to an optical drive or USB drive to install an operating system if it is enabled.


Thanks a lot for your reply. I have tried but that is not solving the problem. Somehow my laptop likes only Fedora 27 :slight_smile:. Any other suggestions. Please help me.

We are missing a lot of information to assist you with:
Its hard to believe that a machine with this spec cannot boot Fedora 31+ from USB

  1. Are you dual-booting?
  2. if so, have you considered disabling FastBoot in your BIOS like @ersen suggested?
  3. Have you disabled fastboot/hibernation in Windows 10?
  4. Are you booting with UEFI support or are you using Legacy BIOS support?
  5. Is the HDD decice boot order in your BIOS correct?

What is that? Two ISO’s in one USB? Explain what you did.
Since Fedora Media Writer did not work for you, have you tried creating a bootable USB using rufus and Fedora-31 ISO? (assuming you still access Windows on that machine). Did it not recognize the USB still?

1 Like

Thanks for your reply. I don’t have windows installed in that laptop. When I purchased the laptop it came without any OS. First OS that I have installed was Fedora 27 using bootable USB. Now only that portable usb alone is working. I am suspecting whether I made any mistake while doing that.

Pl find answers for other queries:

Are you dual-booting? : While booting though it shows Fedora 27, Fedora 29, Fedora 30 but still if I select them also finally it ends up booting only in Fedora 27.
if so, have you considered disabling FastBoot in your BIOS like @ersen suggested? : I have disabled FastBoot still its not recognizing the bootable USB
Have you disabled fastboot/hibernation in Windows 10? : NA
Are you booting with UEFI support or are you using Legacy BIOS support? : It displays while booting that UEFI support. <Not having much idea on this>
Is the HDD decice boot order in your BIOS correct? : While booting if I check booting order it shows Fedora first then my first USB port then second USB port then Windows Boot Manager etc.

In fact just now I tried using UnetBootIn and directly installed Ubuntu on harddisk. Though it said installed successfully while booting still it was displaying Fedora 27,29,30 as usual and opening in Fedora 27.

Any other inputs you need kindly let me know.

Do you have secure boot enabled in BIOS? If so, try to disable it.

EDIT: Also, make sure USB is first in your boot order.

1 Like

Thanks for the reply. I have already brought USB as the first in the bootable sequence in BIOS but still no change.

Not sure about secure boot enabled. Where it will be there in boot screen? If I disable it, will I be able to enable it again? If you could tell steps to do that it would be great. Thanks.

You mentioned disabling fast boot in BIOS. Definitely good idea. Another setting in BIOS that could give you troubles booting from USB is called secure boot. And again, you should be able to find it in the BIOS settings if your BIOS/UEFI supports it.

1 Like

Today I have upgraded from Fedora 27 to 28. Though upgrade got completed but still laptop not booting in Fedora 28.

What did you do to get it to F28?
Please share your GRUB Menu & Parameters?

Otherwise, there seems to be something really weird going on inside that box of yours my friend. If I found myself in that kind of scenario, I’d just grab an external drive (backup), transfer all valuable data to that, and format the HDD inside the PC.

I would then start on a very clean slate. (No F27, F28, Ubuntu???, F-whatever on it… completely blank stuff) I’d probably reset the partitions to one unallocated disk space.

Then I’d fire away with F31 and get things back in order (with step-by-step guidance … gradually like that)

1 Like

I’m not yet sold on HDD being the issue, since the same problem is happening with live USBs. Even though at this point I’d try to wipe it too, just in case.

Can you boot from the non-working USBs on any other machine? Are you using the same USB for F31 as for F27? Are you using the same method to create F31 USB as with F27?

Have you found the secure boot setting in BIOS?
I’m really curious whether it could cause something like this.
Secure boot normally allows to boot only that what matches the signatures stored on tpm chip.
I’m thinking… since the first ever installed OS was Fedora 27, what if it managed to store it’s keys on the tpm chip and now secure boot is stopping everything else, except F27 from booting?

Bare in mind, I’m not exactly sure how this works and could be completely off, but if you can find the secure boot option, let me know if that makes any difference. I’m really curious. :]

1 Like

Following the history of this case, changes may have also gone into /boot/efi and /boot … It’s not clear what methods were taken with all the different installations and what parameters were changed in the system. So … Ah (never mind)

1 Like

Thank you so much friends (phalkon, twohot and others) for your time and effort. As you have suggested I have disabled secure boot. Now it started recognizing the bootable usb. It allowed me to install Ubuntu. As you exactly suspected to my wonder (first upgrade that I have done from 27 to 29) when I chose 29 from the list of menus while booting it login to 29 :slight_smile:

Fedora 29 also seems to be also out of support. Do I need to upgrade to 31?

Any specific suggestions on upgrade.

Once again thank you so much for all of your time and support.

1 Like

Thanks for the reply. Secure boot is a nice feature that could save you if something for example tampered with your bootloader, but it could also bite you in case the tampering was legitimate. That’s probably what happened in your case. :]
It also happens with Linux distros quite often that something is missing a signature and thus secure boot will prevent the system from booting after an update.
You could try to figure out how to update the signatures and keep using it but personally I’d leave it disabled, especially for Linux distro, since it’s more headache then it’s worth.

You should definitely move up from F29 to at least F30. But since it’s getting close to it’s end of life, I’d recommend F31.
You could do upgrade from F29 to F31 but it’s recommended to go up just 1 release with an upgrade. F29 → F30 → F31.

In your situation, since you’re moving from the original F27 installation, it would probably be best to do clean install of F31. You can keep your /home with all your files but wipe everything else.
Since you’re keeping /home, most of your settings will stay but you’ll have to reinstall all the software. It’s definitelly more work then simple upgrade, but it’s less likely to give you headaches down the line.
If you’re not comfortable with custom partitioning during install, you could just move you’re whole /home directory to external storage before installation and that copy it back afterwards. It’s safer this way, since you can be sure you won’t wipe it by accident during installation.

But all this is just my recommendation. Happy upgrading. :]

1 Like

Thanks phalkon for the reply. As suggested by you I will keep the secured boot disabled.

Will also upgrade. As I have done lots of configurations and installations like Ananconda taking /home copy will work? I believe single partition is created for root, home etc because in file manager it shows everything under single group (drive).