Fcitx 5 on Plasma 6 gives bogus notification

Fcitx 5 is set up according to

https://fcitx-im.org/wiki/Using_Fcitx_5_on_Wayland#KDE_Plasma

I get a bogus notification saying:

Fcitx should be launched by KWin under KDE Wayland in order to use Wayland input method frontend. This can improve the experience when using Fcitx on Wayland. To configure this, you need to go to “System Settings” → “Virtual keyboard” and select “Fcitx 5” from it. You may also need to disable tools that launches input method, such as imsettings on Fedora, or im-config on Debian/Ubuntu. For more details see Using Fcitx 5 on Wayland - Fcitx

There is no button saying Don’t show again.

I have already done the system settings part like 7 times, trying both fcitx 5 and fcitx 5 wayland launcher (experimental). Both GTK_IM_MODULE and QT_IM_MODULE are unset according to echo command on konsole. imsettings has been removed using dnf.

Similar issue with maliit keyboard:

Operating System: Fedora Linux 40
KDE Plasma Version: 6.0.3
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.2
Kernel Version: 6.8.2-300.fc40.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 2 × AMD E2-9000e RADEON R2, 4 COMPUTE CORES 2C+2G
Memory: 3.7 GiB of RAM
Graphics Processor: AMD Radeon R2 Graphics
Manufacturer: HP
Product Name: HP Laptop 14-bw0xx