Fc35 packages in Fedora 36

Updated my setup to Fedora 36 (upgrade from 35) a couple of days ago.
Decided to do a package cleanup.
Notices that there is quite a few packages with other fc tags in them (all the way down to fc30).
Is that supposed to be happening?

Tried removing it and installing one back (tbb), dnf insists it’s a fc35 package, coming from fedora repository. I don’t have any hardcoded 35 repository links in yum.repos.d.

Attempting to remove one, e.g., netty3-3.10.6-7.fc31.noarch, drags a bunch of dependent packages with it, quite a few from fc36 (e.g. xstream).

Full list: fc36 older packages - Pastebin.com

1 Like

Yum might try running sudo dnf distro-sync to get them updated to f36.


@vwbusguy No such luck. I tried: fc36-tbb-reinstall - Pastebin.com
However, it seems that all my sources are current, and it’s in fact so, that FC36 repository has fc35 packages (and I’d imagine older) in it:

I wonder how “normal” this is, though. Maybe a space saving measure?

1 Like

In the repository for Fedora 37 you find quite a few packages with “fc35” in the name.

[vek@newbox ~]$ dnf -C list |grep fc35 |wc -l

However, you can run

dnf -C list extras

to get a list of installed packages which are not in the repositories.


tbb wasn’t built for f36, so in f36 you get the .fc35 build. For f37 you get a newer build of the same source…, see https://koji.fedoraproject.org/koji/packageinfo?packageID=5805

dnf info tbb
Installed Packages
Name         : tbb
Version      : 2020.3
Release      : 12.fc37
Architecture : x86_64
Size         : 490 k
Source       : tbb-2020.3-12.fc37.src.rpm
Repository   : @System
From repo    : fedora

netty3 should have been removed from your system with F32, since F31 is the last release it was built for: https://koji.fedoraproject.org/koji/packageinfo?packageID=17654
You can try to remove it with dnf using the --noautoremove flag.