FC30 can't login after kernel update to 5.3.6-200.fc30.x86_64 on crypted LVM


I have just upgraded my kernel on FC30.
I was using 5.2.18-200.fc30.x86_64 but it got updated to 5.3.6-200.fc30.x86_64.
I have crypted LVM :

nvme0n1               259:0    0 238,5G  0 disk  
├─nvme0n1p1           259:1    0   286M  0 part  /boot/efi
├─nvme0n1p2           259:2    0   476M  0 part  /boot
└─nvme0n1p3           259:3    0 237,7G  0 part  
  └─meekhan           254:0    0 237,7G  0 crypt 
    ├─rootvg-rootlv   254:1    0 225,7G  0 lvm   /
    └─rootvg-paging00 254:2    0    12G  0 lvm   [SWAP]

In the attached image here is what I can see and do:

You can see the dmesg output when I try to decrypt the partition and the systemd-cryptsetup output.

With all other kernels – from Fedora project and my own – I can decrypt my LVM.

Any ideas? Help needed…

1 Like

and here is how the LUKS partitions looks like:

LUKS header information for /dev/nvme0n1p3

Version:       	1
Cipher name:   	aes
Cipher mode:   	xts-plain64
Hash spec:     	sha256
Payload offset:	4096
MK bits:       	256

Is it possible that aes-xts-plain64:sha256 is not supported by that kernel?

Further investigation reveals that in initramfs-5.3.6-200.fc30.x86_64.img there is no dm-crypt.ko module. But how come? How to fix it?
This module is in /lib/modules:

    # find -iname "dm-crypt.ko.xz"

But it does not get into initramfs, even when I run dracut -f manually.

How to fix it?

Try this:

sudo dracut --force --regenerate-all

Hello vgaetera.

That did not solved the issue. But I now know what was the problem. Just a dracut unexpected, by me,
I was running myself brewed kernel. Looks like dracut checks which kernel modules are
loaded on running system and includes the same in initramfs of specified kernel.
So, my kernel does not have dm-crypt module as it is compiled in the kernel.
That is why dracut did not included it in any initramfs I was building with my kernel running.

1 Like