Fatal update issue on Fedora 32

I tried asking about this issue earlier, to no avail. I figured I’d lay it all out clearly and hope someone has a solution.

The issue:
After I install Fedora, there are various updates I need to install. In Gnome Software (or through dnf) I click update and everything seems to work. It says it needs to restart to perform the updates, so I do so. After a few reboots and after the loading screen from installing the updates, the screen goes black and never leaves this state.

Any attempt to open a terminal, reach the GUI, etc., all fail. It is an endless black screen.

After some time (hours, even) sitting at this black screen, I force a shutdown by holding the power button until the machine stops (I know, this is really dumb, but there’s nothing else to do). I can then insert my Fedora USB and install the system again. But, again, when I try to update, it fails horribly.

I verified my .iso so everything’s fine there.

Fedora works great as long as I don’t update anything. But I can’t use Fedora long if I can’t update.

As I said earlier, I tried installing updates through dnf, but that didn’t work either, the updates installed, but after rebooting, I get the same black screen.

The updates:
Most of these updates are to upgrade Gnome to 3.36.2, with a few misc updates and one OS update (with a ton of info so I’ll leave that out).

Is there, perhaps, a way to download an .iso with everything updated, or is there a way to bypass this update or something?

My hardware:
2015 MacBook Pro
Intel Core i7
15.5 GiB RAM
Graphics: Intel Corporation Crystal Well Integrated Graphics Controller

I’ve installed and used probably 15+ different linux distros, and this is the only problem I’ve had.

I sincerely appreciate any help anyone can provide.

1 Like

Hi jwytycfmu,

could you try an install without Gnome and e.g. choose a KDE install (at software selection) to see if the problem persists?

You can try one of the updated ISOs that the respin SIG generates:


However, if it’s related to a particular version of the package, this may not fix the issue. The issue is not related to the act of upgrading, it is probably related to the new version of a package after the upgrade.

If this happens again, can you please press a key during the boot process to see where the boot hangs? You can also edit the grub command line to remove rhgb quiet and that’ll show you the boot process in detail:

  • in grub, press e to go to edit mode
  • scroll down to the line that starts with linux ... that contains rhgb quiet
  • remove rhgb quiet and then boot as per instructions there (ctrl x I think)

The look at the boot process and see where it stops.

Is this not a duplicate of https://discussion.fedoraproject.org/t/fedora-freezes-after-updating-software-through-the-software-app-fedora-32/73475

Could very well be, but we don’t have enough information to say so just yet.