Failure to boot after upgrading to Fedora 34

I upgraded from Fedora 33 to 34 recently, and the first time it booted everything was working as expected.

However, the second time I tried booting…well, it gets past the BIOS POST, I think, but doesn’t get any further than that. Normally I see a Dell logo in the middle of the screen during POST and then Dell + Fedora Fedora logo at the bottom as the OS boots, but now it never gets past just the Dell logo; it just hangs. I dual boot with Windows, but I disable the Windows drive in the BIOS when booting Fedora so the “only OS” is Fedora.

Other details:

  • Dell XPS 9570
  • UEFI enabled, Secure Boot disabled

I can’t even get to any kind of logs, or anything but the Dell logo, though also I don’t really know what I should be trying. I tried holding down LShift during boot and that does nothing.


It may have used (shared) the EFI partition on the Windows drive for its bootloader. Consequently, you may have to have the Windows drive enabled in order to boot Fedora Linux. I’m not sure how the installer handles that case (2 drives, 1 EFI partition), but that is at least a possibility.

Another possibility is that the second EFI partition on the second drive (if you do indeed have 2) is no longer listed in your PC’s UEFI firmware. The UEFI BIOS should automatically find the EFI partition when drives are added/removed, but sometimes they don’t. Sometimes they expect the EFI partition to be the first one on the disk and oftentimes they expect it to have a specific type code. I think I even heard someone say that they can be hard coded to look for the MS Windows UEFI bootloader instead of the default defined in the spec – /efi/boot/bootx64.efi.


Hi @glb, thanks for the response. You gave me some good ideas looking for bootloaders, and…when my main drive (with Windows) is disconnected, I had exactly one boot entry with this path: \EFI\boot\bootx64.efi. I decided to create a new entry with the path \EFI\fedora\shimx64.efi and that worked perfectly. Unfortunate that the upgrade altered that somehow, and I’m not sure what the value was previously, but in any case things are looking fine now. Thanks again!

In summary, if it’s not booting the OS at all and you’re booting with UEFI, check the boot entries…not just the drive, but the actual EFI path it’s using.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.