Failing to install python3-scrapy

Hi all,

I am trying to install scrapy, but installation fails:

dnf install python3-scrapy 
Last metadata expiration check: 0:12:28 ago on ??? 18 ??? 2023 06:37:18 ?? EET.
Error:
 Problem: conflicting requests
  - nothing provides (python3.12dist(twisted) < 23.8~~ with python3.12dist(twisted) >= 18.9) needed by python3-scrapy-2.10.1-1.fc39.noarch from fedora
(try to add '--skip-broken' to skip uninstallable packages)

How can I fix this?

Twisted is at 23.10 so the dependency rule breaks

You need the pyrhon-scrapy maintainer to fix the packaging.
Raise a bug in fedora bugzilla to get this fixed.