Failed to set new efi boot target error on install

Hello, I am a linux noob who would like to install fedora, but when I try to do it I just get an error when it tries to install the bootloader (that being failed to set new efi boot target). I am dual-booting windows (plan to keep windows) and linux mint (recently deleted the mint partitions to make way for fedora).

When I proceeded with install while still having the error, it just booted into grub recover mode. I am using UEFI/Legacy boot, with Legacy set to first. Whenever I try to boot into pure Legacy, it refuses to boot the live session. My computer is a lenovo thinkpad t480s. At the boot menu it does show ubuntu (maybe grub? idk), which I assume might contribute to the problem as when I look on other posts it does show that instead of that it shows fedora.

Please help!

Added desktop, dual-boot, efibootmgr, gnome, nvidia

this is a recipe that leads to exactly what you are seeing.

What boot mode does window use?
If windows is set to uefi then fedora must be set to boot uefi as well or you will not be able to use grub to boot both.
The same applies if windows is installed in legacy (MBR) boot mode. They must both be booting in the same mode.

To fix this I would do the following

  1. set the bios to boot uefi only (assuming windows boots in uefi mode)
  2. boot to the live install media
  3. run lsblk -f to confirm that there exists an efi partition on the hard drive.
  4. If step 3 shows an efi partition and you wish to remove all traces of mint then you must mount the efi partition. Assuming that partition may be something like /dev/sda1 then the mount command would be something like this.
    a. su
    b. mount /dev/sda1 /mnt
  5. following a successful mount then run ls /mnt/EFI to see what is there.
    I would expect to see directories something like Microsoft & ubuntu along with a couple others.
  6. Complete the removal of mint boot files with rm -r /mnt/EFI/ubuntu/. If you are comfortable and very careful in how you type that command you may use -rf instead of -r to avoid the need to confirm each and every file being removed.
    Following the removal of the remaining parts of the mint install then continue
  7. verify that none of the mint partitions (or partitions from your failed install) still exist
  8. reboot to the install media and perform the install. It may take quite some time for the installation of the boot loader to complete so be patient and do not interrupt the install. Allow it to finish and return with the message of success.

If windows is booting in legacy mode then the parts here about the efi partition are not valid, so take that into consideration.

Even though I did this, it doesn’t seem to work and still gives the same error. This is probably because I deleted the previous efi partition. Is there a solution to this?

You say you deleted the efi partition.

That means you will need to recover the windows install (potentially even reinstall windows) before installing fedora or go through a lot of hoops if you install fedora first then follow with a windows recovery.

1 Like

Well in the end I completely removed windows, and that worked. Thanks nonetheless for your help!

2 Likes