Failed to install Bootloader during live USB install

I installed a new version of fedora via live USB stick with automatic partitioning. During installation it said the following.
The following error occured wile installing the boot loader. The system will not be bootable. Would you like to ignore and continue with installation? Failed to set new efi boot target. This is most likely a kernel or firmware bug.
On booting the system I get
error> unknown filesystem.
Entering rescue mode…
grub rescue>
I went on to install anyways, since I have also tried a manual partitioning before, where I got the same result. Currently I run the liveUSB version, and the installation ist mounted here

I thought about updating my BIOS/UEFI, but it seems that for my PC has the latest version installed (2013/08/07)

Are you still working with that Windows7 you have installed? If not, i really propose you to clean up the data (Making a backup somewhere else than on the laptop, for the Windows data and the Fedora data).

After you start over cleaning the Hard-drive (format) and create a partition table (GPT). Then you will be able to automatic install fedora as UFI.

What you have now is MBR probably installed automatically while installing Win7.

In bios you have to activate UFI and deactivate Legacy boot to avoid that your laptop forces a legacy installation.

1 Like

Don’t forget to read the change log from Fedora 33 when BTRFS has been introduced as default.
Releases/33/ChangeSet - Fedora Project Wiki

Thanks! As you said, I completely formatted my HD with GPT and was then able to successfully install fedora36.