F40 Plasma 6 fresh install: panel > tray > expandable context menus rendering issue

I did a fresh install on bare metal today after experimenting a lot with composing a kickstart for my needs, and the resulting system has an issue that is driving me crazy and that did not exist in my past installs of F40 Plasma on either VMs or (the same) bare metal.

Info: Intel UHD Graphics 620 (no other/hybrid graphics)
Note: The exact same system was running fine since F40 pre-beta releases, and up to earlier today

The tray items, on-click, should expand into a context menu, like so:

.
However, once an application opens and the floating panel “docks” to the bottom (bottom is only for reference, tested and the issue remains with different panel positioning at top/sides), the context menus are no longer accessible. In their place, a tiny rendering appears that on-hover produces the option to “drag to resize”, which of course doesn’t do anything, not consistently at least…

Screenshot_20240430_005104

.
SOME times, it results in a weirdly positioned context menu :

After which, closing and reopening the tray item works as expected, until the floating state of the panel is toggled again and the issue reappears.

I tried to set the panel to non-floating with the assumption that if I manage to trigger the misaligned rendering the issue will be resolved for the rest of my session, but then the tiny rendered window never produces that “mis-aligned” context menu, so the issue cannot be resolved at all during that state.

Any pointers on how to tackle this would be highly appreciated, I’m not even sure what the packages responsible for those context menus are exactly…

The system is so “fresh” that the first thing that passed my mind was to try a fresh install again (just can’t do that atm as I need a running system for now, will probably try that tomorrow if not resolved).

The relevant package section of my kickstart for context:

%packages

@^kde-desktop-environment

-akonadi*
-krfb
-mariadb*
-kwrite

%end

Removed beta

This sounds like 485456 – With Qt 6.7, System Tray popup is inappropriately resized to a tiny nub

There is currently a fix in progress:

It’ll likely be in a subsequent bug fix for KDE

2 Likes

Thank you for the fast reply!
Yeah, it does seem like the exact issue I’m facing, so I’ll track it there.

Are you by chance aware when Plasma started getting built against Qt 6.7 in Fedora?
I’m just trying to figure out how come I didn’t face that before… did it just land today or…?

I believe it was during release of Plasma 6.0.4 which would have been around a week ago or so… although I may have been on Updates-Testing so I may have received it earlier than you

Yeah, ok, that was probably some bad timing for me…

After a bit of research, 6.0.4 did indeed hit testing ~week ago
Pushed to testing: 19-04-2024
Pushed to stable: 26-04-2024

So maybe a day or two of out-of-sync mirrors, a day or two of me not fetching updates, and the mystery is solved…

6.0.5 is scheduled for 21-05-2024 so I’ll probably have to look for manual intervention…

If you update you will get 6.1 as kde sig skipped over the 6.0.x series.

Would you mind to elaborate?

Here is the bodhi update that (I assume) introduced the issue by building against Qt v6.7.
plasma-desktop is on v6.0.4 on F40 stable since 26-04-2024

I don’t think this is accurate as the current version is 6.0.4 in the repos. KDE sig has discussed holding the 6.1 series for Fedora 41 or perhaps doing a COPR for F40 but I don’t think this has been finalized. @ngompa or @farchord could you clarify?

We intend to ship Plasma 6.1 to Fedora 40 users. We have not changed our policy. Plasma 6.0.4 just went out last week.

1 Like

Odd… I have kf6 RPMs for 6.1 installed. I don’t think I turned on testing repos.
DNF does not think I installed from testing.

$ rpm -qa |grep ^kf6
kf6-filesystem-6.1.0-1.fc40.aarch64
kf6-kcodecs-6.1.0-1.fc40.aarch64
kf6-karchive-6.1.0-1.fc40.aarch64
kf6-kdnssd-6.1.0-1.fc40.aarch64
kf6-kdoctools-6.1.0-2.fc40.aarch64
kf6-syndication-6.1.0-1.fc40.aarch64
kf6-attica-6.1.0-1.fc40.aarch64
...
$ dnf info kf6-filesystem
Last metadata expiration check: 0:01:15 ago on Tue 30 Apr 2024 22:07:30 BST.
Installed Packages
Name         : kf6-filesystem
Version      : 6.1.0
Release      : 1.fc40
Architecture : aarch64
Size         : 1.5 k
Source       : kf6-6.1.0-1.fc40.src.rpm
Repository   : @System
From repo    : updates
Summary      : Filesystem for KDE Frameworks 6
URL          : http://www.kde.org
License      : BSD-3-Clause
Description  : Filesystem for KDE Frameworks 6.

This is on two of my systems an ARM VM and a X86 desktop.

Ah, you’re looking at KDE Frameworks. KDE Plasma and KDE Frameworks are on different release cycles as far as I recall. KDE Frameworks 6.1.0 was released April 12th however KDE Plasma 6.0.4 was released April 16th. For Plasma, 6.0.4 is what is currently in the repos.

Going forward, the Frameworks will likely get updated more frequently as KDE transitions Plasma to a 6 month release cadence.

1 Like