F40 Change Proposal: nginx 1.25

It would be fine if nginx 1.25 or later will be included in F40. nginx 1.25 supports http3 / quic