F38, Intel Skylake, Xorg and kernel 6.4.9

my brother running a notebook (F38, Acer Aspire E5-574-525M) in USA (I remote admin him via anydesk from Europe) got trouble running kernels beginning with 6.4.9.

It seem (I haven’t seen it myself) the kernel boots correct, but when it comes to the graph. login the screen goes black and nothing anymore.

GPU is Intel i915 and runs Xorg (cause of anydesk)

We have tried without “quiet rhgb” and journal doesn’t show something what could cause it.

I have searched (not in deepth yet) the bugzilla’s, but I couldn’t find something.

Anyone have an idea how to debug this or an hint ?

we will try wayland next time …

What GPUs are installed?
Please post the output of inxi -Fzxx

I currently have no access to the device.

only the Intel iGPU: Intel HD Graphic 520


Notebook is running with Fedora since years (since 12/2015)

dmesg|grep -iEw 'bad|bug|conflict|corrupt|error|fail|failed|fault|fatal|invalid|Lock|NULL|segfault|stack|trace|warn'

on an working kernel (6.4.6) shows solely this:

[ 0.037873] mem auto-init: stack:all(zero), heap alloc:off, heap free:off
[ 0.135613] MDS CPU bug present and SMT on, data leak possible. See MDS - Microarchitectural Data Sampling — The Linux Kernel documentation for more details.
[ 0.135613] MMIO Stale Data CPU bug present and SMT on, data leak possible. See Processor MMIO Stale Data Vulnerabilities — The Linux Kernel documentation for more details.
[ 0.180037] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[ 0.194759] PCI: Using host bridge windows from ACPI; if necessary, use “pci=nocrs” and report a bug
[ 8.250036] i2c_hid_acpi i2c-ELAN0501:00: failed to reset device: -61
[ 13.210009] (sd-execu[476]: /usr/lib/systemd/system-generators/ostree-system-generator failed with exit status 1.
[ 13.513510] systemd[1]: Mounting sys-kernel-tracing.mount - Kernel Trace File System…
[ 13.563109] systemd[1]: Mounted sys-kernel-tracing.mount - Kernel Trace File System.
[ 15.911239] vboxdrv: module verification failed: signature and/or required key missing - tainting kernel
[ 111.013590] process ‘23f89591d86c8f881c527f0637e7004f6c7aa5f82e01454f816a3b7f66686d81/files/extra/anydesk’ started with executable stack

what we have also done:

  • 6.5 rawhide kernel
  • several boot parameter
    • systemd.unit=multi-user.target (=> runlevel 3)
    • systemd.debug-shell=1

and ctrl+alt+backspace ( restart X)

nothing !
screen goes just before graph. login black and the box seems dead

inxi -Fzxx

  Kernel: 6.4.6-200.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.39-9.fc38 Desktop: GNOME v: 44.3 tk: GTK v: 3.24.38 wm: gnome-shell
    dm: GDM Distro: Fedora release 38 (Thirty Eight)
  Type: Laptop System: Acer product: Aspire E5-574 v: V1.18 serial: <filter>
  Mobo: Acer model: Zoro_SL v: V1.18 serial: <filter> UEFI-[Legacy]: Insyde
    v: 1.18 date: 05/25/2017
  ID-1: BAT1 charge: 31.0 Wh (90.1%) condition: 34.4/37.0 Wh (92.8%)
    volts: 16.2 min: 14.8 model: SANYO AL15A32 serial: <filter>
    status: discharging
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M335
    serial: <filter> charge: 50% (should be ignored) status: N/A
  Info: dual core model: Intel Core i5-6200U bits: 64 type: MT MCP
    arch: Skylake rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 500 min/max: 400/2800 cores: 1: 500 2: 500 3: 500 4: 500
    bogomips: 19200
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Acer Incorporated ALI
    driver: i915 v: kernel arch: Gen-9 ports: active: eDP-1 empty: DP-1,HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:1916
  Device-2: Sunplus Innovation HD WebCam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 1-7:4 chip-ID: 1bcf:2c81
  Display: server: X.Org v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x15c4 res: 1920x1080 dpi: 142
    diag: 394mm (15.5")
  API: OpenGL v: 4.6 Mesa 23.1.5 renderer: Mesa Intel HD Graphics 520 (SKL
    GT2) direct-render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d70
  API: ALSA v: k6.4.6-200.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.77 status: active (process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168
  IF: enp1s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Foxconn driver: ath10k_pci v: kernel pcie: speed: 2.5 GT/s lanes: 1
    bus-ID: 02:00.0 chip-ID: 168c:0042
  IF: wlp2s0 state: up mac: <filter>
  Device-1: Foxconn / Hon Hai driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 1-5:3 chip-ID: 0489:e09c
  Report: rfkill ID: hci0 rfk-id: 4 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 465.76 GiB used: 163.36 GiB (35.1%)
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
    speed: 6.0 Gb/s serial: <filter> temp: 25 C
  ID-1: / size: 48.91 GiB used: 9.33 GiB (19.1%) fs: ext4 dev: /dev/sda2
  ID-2: /home size: 353.28 GiB used: 154.04 GiB (43.6%) fs: ext4
    dev: /dev/sda3
  ID-1: swap-1 type: zram size: 7.61 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda4
  System Temperatures: cpu: 37.0 C pch: 35.5 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 233 Uptime: 1h 54m Memory: available: 7.61 GiB
  used: 1.4 GiB (18.4%) Init: systemd v: 253 target: graphical (5)
  default: graphical Compilers: gcc: 13.2.1 Packages: pm: rpm pkgs: N/A
  note: see --rpm pm: flatpak pkgs: 6 Shell: Bash v: 5.2.15
  running-in: gnome-terminal inxi: 3.3.27

for the record:

boot parameter for kernel 6.4.11


fixed it.

and of course switches all hw-Bug-fixes off (I know ! )

maybe with the upcomming kernel 6.4.12 there will be some changes to leave the boot parameter away …

+++ Edit +++
it seems the box has still trouble …

+++ Edit update +++
kernel 6.4.12 seems to fix it (and boots without “mitigations=off” too)

knock wood