F37 - Jittering in Desktop Environment

I’ve used Ubuntu for 2 years and finally decided to try a new distro and I chose fedora. I now made myself a boot stick and booted into the stick for the first time and right away I noticed that the whole desktop environment is extremly glitchy. Even after I installed fedora the problem didn’t go away. I tried manually installing new drivers for my rtx 3070 but that only made it worse. I then tried a different operating system (debian) and it just used the standard resolution. it seems to me that it either my graphics card or my display has a problem but I have no idea how to troubleshoot this.
I hope someone recognises this problem and thanks for any help.

My rtx 3070 is the problem. I swapped it for my 2060 and all the problems vanished.

I assume you meant that you installed the nvidia drivers. I hope you did so from the rpmfusion repo.

If your system is fully updated it should support the 3070 GPU, but if not updated it may not support that newer card.