F36 Silverblue Missing Nvidia Vulkan

Hello. First time poster. Foremost, thank you for the incredible operating system. I may simply switch back to workstation for simplicity’s sake (should I find no solution), but I admire the principles of silverblue, and I would to remain with it.

I use a laptop with both intel and nvidia GPU. I don’t switch graphics, but I launch some programs like steam with discrete graphics. Vulkan is missing on all flatpaks—steam, lutris, vulkaninfo, etc. I’ve yet to test any layered packages. This is a recent development. My system was fine only less than two weeks ago.

When running flatpak run org.freedesktop.Platform.VulkanInfo with the intel card, everything is fine. The Nvidia card, however, yields the following output:

ERROR: [Loader Message] Code 0 : loader_get_json: Failed to open JSON file /usr/share/vulkan/icd.d/nvidia_icd.json
Cannot create Vulkan instance.
This problem is often caused by a faulty installation of the Vulkan driver or attempting to use a GPU that does not support Vulkan.
ERROR at /buildstream/freedesktop-sdk/extensions/vulkaninfo/vulkan-tools.bst/vulkaninfo/vulkaninfo.h:693:vkCreateInstance failed with ERROR_INCOMPATIBLE_DRIVER

I have tried reinstalling my nvidia drivers (with the instructions from Howto/NVIDIA - RPM Fusion). I have also tried reinstalling all flatpaks. No change. I don’t know what could have gone wrong.

I’m using version 36.20220602 and the default nvidia drivers installed using the above guide were 510.68.02.

If anyone has any advice or needs more information, I’d truly appreciate a response.

Update: I have done some more troubleshooting to determine where the issue is.

  1. I rolled back the base image to one that is older than when I encountered the issue. The issue persisted.
  2. I layered vulkan-tools and ran vulkaninfo using the nvidia GPU. It worked without issue.

It therefore seems to be a flatpak issue.

probably something on your side because I didn’t have vulkaninfo installed and because of you I did (flatpak) just now to test and worked without problems

I’m running on an hybrid laptop AMD/NVIDIA with the latest kernel (5.17.12-300.fc36.x86_64) and NVIDIA drivers (510.68.02) and got both GPU info from the command

See this: Vulkan broken inside Flatpak (#30) · Issues · Bastien Nocera / switcheroo-control · GitLab