F36 is using Xorg instead of Wayland

Hello I am a new user of fedora and Linux in general so please be gentle. :slightly_smiling_face:

I have recently upgraded from fedora 35 to fedora 36 and I noticed that it was much slower.
When I went to the settings app, in the about section it said it was using X11 and also that the ram installed was 2gb when it is actually 4gb.
Moreover, when I close the laptop’s screen, the second monitor gets much slower, but when I reopen it, it works as previously.

Also if I run the command “echo $XDG_SESSION_TYPE” it outputs x11

Hello. A couple of questions:

  • Have you rebooted your laptop? If you have, has it changed anything?

  • In the GNOME login, there’s an option at the right bottom (AFAIK) where you can change between X11 and Wayland, could you change that and check if it worked? And if it stays after a reboot?

  • How many RAM sticks does your laptop have? If you have 2x2GB, can you try opening up, removing them and adding them again? If it still fails to show the other 2GB, can you do a Memtest (I think the Fedora ISO has the memtest tool) and report back?

Hello, thanks for the quick answer.

Yes, I have rebooted the laptop several times and even reinstalled it twice, but the issues persists.

In the GNOME login, there are only two options: GNOME or GNOME Classic.
I supposed that the GNOME one, should have wayland by default, but in my case it does not.

Also, the RAM seems to work find because the system monitor and htop recognize the 4gb but with almost 2 of them y cache which i don’t know if it’s normal. However it seems to be a Settings app problem as the other tools recognize the 4gb well.

Also, the problem with the second monitor persists, it is like if the input was delayed.

1 Like

Just to be sure, can you do a Memtest?

Also, just making sure, you performed a system upgrade, correct? Or did you clean install?

I have made the memtest86 test and it passed OK with 0 Errors, it recognizes the two slots of 2gb RAM also.

I have twice upgraded from fedora 35 to 36 and also I have make two clean installs of fedora 36

Hello @goorge ,
Fedora Linux uses ZRAM for swap usage instead of disk swap in a default setup install. So if you type swapon --show it will show you your swap device, if it is using ram it will show (likely 2GB) so this could explain your ram that your missing. You can choose to make a swap partition like normal BTW, but you would need to do some reconfiguring.
The other thing I would suggest is the video device itself, if it is an nvidia device there may be some steps necessary for you to get to your desired wayland session.

1 Like

Hello, thanks for the answer.

Yes it is using RAM for the swap.

I don’t have an NVIDIA graphics card, the laptop has AMD and Intel graphics.

Also I’ve noticed that when the laptop screen is closed. The frames of the external monitor drops to 1fps.
I know that it is working at 1fps because I have made two screen recordings an the one that is with the screen closed, displays at 1fps.

That seems like a bug to me, it should just hibernate (no output activity) I would think.
Did you change to a swap partition on physical disk? To free up ram.

1 Like

You must first check RAM & Swap has Stephen said before…
Then please ask to Linux what about your memories :slight_smile:

As seen there is 3 easy ways :

  1. Use free to ask Linux to show the amount of memories
  2. Use top to ask Linux to show the amount of memories
  3. Use htop to see it graphically and dynamically ( dnf -y install htop; )

( Ask you can see on ‘top’ I’m using Cinnamon Desktop on Xorg ; Forget the 3.8 Go of RAM used : It is because I’m updating Fedora and the Browser is running Usually the RAM is about 1.2Go on 16Go dispo )

Hi again
To check if you have a physical swap : use df and, easier, lsblk