F34 vs. Porteus on whether Wi-Fi works on one Dell E4310 only

I can’t get Wi-Fi on one of three highly similar Dell Latitude E4310 refurbished laptops running Fedora 34 live or installed (not yet updated) on HDD with either internal or external Wi-Fi but I can if running Porteus 4.0 Linux live with the same external Wi-Fi USB adapter and I can with the same Fedora live or installed (not yet updated) on HDD on the other two E4310 laptops with internal Wi-Fi. Fedora’s Settings app reveals the hardware strings identifying the internal and external Wi-Fi hardware (“Intel Centrino Advanced-N 6200” and “Realtek 8187B”), likely correctly, but the app either way says “No Wi-Fi Adapter Found” and no networks get listed. Porteus lists at least one network.

In whichever way I got Wi-Fi, I went to a website and verified it.

The live Fedora disc was the same disc everywhere and that same disc was used to install the OS on all HDDs.

I haven’t updated Fedora on HDD yet because I want all 3 machines to be as nearly identical as possible until this is solved and I can’t update the one without working Wi-Fi.

I tried asking at Dell, where they’d know about their hardware, but the post didn’t go through and perhaps you know about any issue with Fedora. Any ideas?