F34 login loop

After trying to login into my user, I immediately return to the login screen without any error messages.

Tried different kernel versions (5.17.12-100, 5.13.15-200 and 5.13.12-200 x86_64).
Also tried switching between GNOME/Xorg/Classic.
I suspect the issue came from installing updates at shutdown.
I am able to switch to a tty login. However, no luck with logging in due to incorrect credentials. Using the same username/password as in the GUI login.

Any solution will be greatly appreciated!
Thank you.

Do you have the live install media (usb).
If you do we can guide you on how to reset your password.
If not then we can assist after you get the live media to boot from.

Also, it is possible to boot to single user mode (as root) by editing the grub command line from the grub menu where you select the kernel to boot.

There you need to press the ‘e’ key after highlighting the kernel you wish.
Once the screen opens up find the line that begins with ‘linux’ and edit that. You will remove the ‘rhgb quiet’ from that line, and add ‘init=/bin/bash’ (or ‘init=bash’). You would then press ‘ctrl-X’ to continue booting.
It now should boot to single user mode with only a text screen and you should be able to use the passwd command to change the password for your user.

Just so you know.
Fedora 34 has been out of support for several months and it is always recommended that you upgrade to a currently supported version if possible.

1 Like

The fedora login password was correct, it just went immediately back to the (tty) login screen after logging in so I assumed it was wrong.

Single user passwd to reset the root password didn’t work for me, I did it using the emergency mode and remounting sysroot with rw permissions.

After logging in as root I disabled all gnome extensions and was able to log in(!)

gsettings set org.gnome.shell disable-user-extensions true

Thank you for the response Jeff!
Updating to f36 now :sweat_smile:

Same issue with f36, previous workaround didn’t help.
This time selinux=0 added to grub did the trick.

In this case you could relabel the entire filesystem with
sudo touch /.autorelabel
Then reboot.