F34 hanging after boot

May I ask what is white screen of death?

1 Like

It is like a white empty Desktop background made by gdm,

telling you to relogin because of unfixable crash . if you do , you come back to the white screen of death, of course.

sometimes, if you press the Windows-key, the gnomeshell app-folder shows.

release the windows-key , and the white screen of death rears its ugly head again.

sometimes, it also has a logout button and an icon like a “crying TV screen”.

or a sad-looking Screen icon.

1 Like

so in my case WSOD (as opposed to BSOD = blue windows crash screen) showed, even though gdm was kind of only semi-crashed.

weird, huh.

so WSOD is like the BSOD for MS Windows of Bill Gates, but white instead of blue.

comes, when the GUI crashed badly and won’t fix easily.

Summary:

This issue happens when the open source radeon drivers is using with gnome 40.1.

While waiting for future updates that might fix this issue, I am doing below as alternatives:

  1. avoid using gnome at the moment
  • Use i3 or sway
  • Use KDE/Plasma. As I use Silverblue, I rebased to Kinoite - which is in rawhide
  1. Do not use radeon
  • by adding two kernel boot parameters, amdgpu is used instead of radeon. But for me, sound over hdmi is not working, so I need to route sound over to bluetooth speakers .

Exactly my situation. I’m using an AMD RX 5700XT. The starting Fedora logo screen displays fine then I end up with the blank screen and blinking top left cursor. Logs are big and confusing so I tried getting what I thought is relevant.

I never got to get Gnome or anything GUI at all to work. I tried previous kernels - no luck.

I hope this helps.

Thanks.

/usr/libexec/gdm-x-session[1431]: (EE) AIGLX error: dlopen of /usr/lib64/dri/swrast_dri.so failed (/usr/lib64/dri/swrast_dri.so: undefined symbol: amdgpu_query_video_caps_info)
(EE) AIGLX error: unable to load driver swrast
(EE) GLX: could not load software renderer
(II) GLX: no usable GL providers found for screen 0
AMDGPU(0): Setting screen physical size to 889 x 277
Xorg: /usr/include/xorg/privates.h:121: dixGetPrivateAddr: Assertion `key->initialized’ failed.

2 Likes

Please help comment at the bug so that it will get more exposure.

2 Likes

OK, I commented using FAS credentials via Epiphany browser and not entering the password myself. cool!

2 Likes

I got a suggestion at: (And this allowd Gnome to start for me)
https://bugzilla.redhat.com/show_bug.cgi?id=1960937#c12

[ Jonas Ådahl] 2021-05-26 20:32:39 UTC

Try adding DRIVERS=="radeon", SUBSYSTEM=="drm", TAG+="mutter-device-disable-kms-modifiers" to /usr/lib/udev/rules.d/61-mutter.rules and remoot.

As I am using Silverblue, which /usr is readonly.

How can I modify udev rules under Silverblue?

Updated below:
OK. I find out how

1 Like

The above suggestion is now publish as a fix ON_QA:

https://bodhi.fedoraproject.org/updates/FEDORA-2021-895047c304

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.