F34 Fresh install boot fails with "Failed to get device path"

I tried a fresh download of the F34 ISO when it was officially released, and opted to wipe and do a fresh install. I followed “automatic partition and also disk encryption”.

However, after installing from the usb pendrive, hard reboot, I get into firstboot setup and the gnome tour. Another hard reboot after that with/without dnf upgrade, boots me into a failed state with the following messages (see pic):

At first, I thought this was due to having secure boot turned off, etc., that turned out to be not true. Happens both with/without secure boot on.

I even tried installing F33 fresh, and upgrading from that, however, results in the same problem. I also turned off encryption and it’s the same. I’m on a Lenovo Thinkpad T480, for what is worth.

Any idea how I could troubleshoot this?

1 Like

For Hard Reboot do you mean it reboot unexpectedly? If it is the case, something is very wrong there.

For a normal fresh installation, it will only reboot once and then it will be Initial Setup, Tour and allow normal use.

Have you check with Lenovo’s Fedora forum?


1 Like

What I mean by “hard reboot” is that I pressed “Poweroff” from the GNOME menu, and then manually turning on the machine back up again, as opposed to “Restart”.

I have not checked that out yet, I shall do that for now. Thanks!

1 Like

GNOME’s “poweroff” option initiates a soft shutdown, not a hard reboot. A hard reboot happens when the power fails, the power button is held down for 3+ seconds, or you pull the power cable (and there is no backup battery). A hard reboot should always be avoided because it can cause file corruption (and lead to the sort of errors that you mention initially).

If there is no hardware problem, then Lenovo’s forum may not be the right place to ask. For Fedora software problems, this is the right place.

It looks like something is wrong with the bootloader. It appears to be dumping the contents of your hard drive to your display. I have never seen one do that before. I guess my suggestion would be to try a different bootloader. Unfortunately, that is not easy to do in Fedora Linux. :confused:


Thanks for the clarifications. I just mixed up the terms while hastily writing this topic. All I wanted to mention was that instead of just “restarting”, I “poweroff” after the install and manually turn on the laptop.

In any case, I tried another scratch install: after installing the Live Workstation image via usb again, i pressed “finish installation”, went to GNOME’s “restart” option. Waited for it to reboot. However, after the BIOS screen instead of taking me to the disk encryption password phase, it gets stuck with just a Lenovo logo. I waited upwards of around 3-4mins (didn’t time it exactly, just a ball park), it reboots and same problem of getting stuck in Lenovo logo screen. So at least somehow, the errors were not spewing again. :slight_smile:

I just reinstalled the same machine (with secure boot on) via the same usb sticks i used, but with F33 this time, it boots and get into the fedora logo and asks me to enter my disk encryption password, as expected.

So I’m lead to believe something is not right with the software rather than the hardware. I’ve been trying different combinations since yesterday so, think I’ll stick with F33 for now on the laptop and also this desktop I’m writing this topic from.

In any case, I’ll see if I can upgrade from F33->F34 tomorrow on the laptop, and report back if anything changes.

Sorry I can’t be of more help. The “Failed to get device path” error is a bit vague. There is a third possibility that might be worth exploring. The “device” is hardware and what is trying to get its path (the bootloader) is software, but there is something between the hardware and the software called … wait for it … FIRMWARE! :slightly_smiling_face: You might try updating the system’s firmware if you are up to it.

Good luck. :slightly_smiling_face:

1 Like

No problem. Thanks for trying! :slight_smile:

On the fresh F33, I don’t see any new firmware updates either.

So I upgraded (again) from F33 to F34 with disk encryption turned on. Reboot and the error from the picture shows up again.

I tried another fresh install of F33 without disk encryption, fully update the packages, use GNOME software center to upgrade to F34, updates, reboots, and stuck at the Lenovo splash screen and it won’t go further.

Funnily enough, this is the first time I’ve had any problems whatsoever with a fresh install of Fedora since I started using it in 2011/2012. :rofl:

Ok, this is pretty weird. I wanted to check if other spins have a similar problem for me, so I tried:

  • KDE - works as expected
  • Server - didn’t get into the install screen
  • i3 - works as expected
  • GNOME via Everything ISO - surprisingly worked as expected

Not sure what differences there are, but this is weird.

1 Like

Hi @mavjs, just out of curiosity, are you doing the installation in the same mode as your system is set to boot, i.e. UEFI vs legacy BIOS?

1 Like

Good question. I believe so. The T480 is set to have “secure boot on” and I see that in the bios it’s booting mode is “UEFI only”, and I’m not touching any settings on the installation media.