F34 distorted login screen, missing form

Hi, I have the following problem with my Fedora login screen:

System: F34, Xorg (upgraded from F33), Lenovo Thinkpad T490s, Mesa Intel UHD Graphics 620 (WHL GT2), external Screen (Dell, 2k) connected via USB-C

When I start my Laptop while it is connected to the external screen and
a) close the laptop lid directly after hitting the start button or
b) configure the laptop’s BIOS to boot at power on (i.e. when I turn on the USB-C screen, the Laptop boots if it is off),
the Gnome-Login-Screen is distorted. It looks like two top-bars over each other and the login-form does not show up at all (see pic1 and pic2).
When I then open up the laptop lid the distorted screen is moved to the laptop screen and the external screen is only filled 1/3 (see pic3 and pic4).

This occurs nearly every time I boot (~8 out of 10 days), I have not detected any pattern, though.
It does not occur when I boot and leave the laptop lid open and close the lid only after I logged in.
The only remedy right now is to hard reboot and leave the lid open until logged in.

I have two colleagues also running Fedora 34 on this TP model and they are also experiencing the same problem.

What could be the reason for this issue? What should I try/test?

Thanks in advance,

pic 1:




It sounds like something triggered by the lid switch may be interfering with the boot.

What is wrong about leaving the lid open for the short time it takes to boot then close it after the system is fully operational?

If you absolutely must close the lid before the boot is complete then track down what is being triggered by the lid switch and stop that action.

Nothing wrong with leaving the lid open. Me and my colleagues would just like to have the choice :wink:

What I found out:

  • This only happens under Xorg. With Wayland the login screen appears normally also with closed lid.
  • It seems that only the login screen is distorted. The login form is somewhere: Under Xorg, when I blindly hit Enter, type my password, and hit enter again I can log in and the session starts normally (once I am on the desktop there are no distortions anymore).

Maybe I’d need some additional gdm-setting?


I found the pages on internet.

Both have same method to fix the problem. Basically it’s copy the current setting of gnome session to GDM. If the file monitor.xml exist and contain info about monitor resolution , may be it could help.

I’m currently on lightdm and i3, and my apologize I can’t test it before making suggestion.


What I suggested above doesn’t work. I just tested with Gnome Xorg session. When I login to Xorg session, the monitor.xml was created. But when I copy it to gdm directory as suggested on link I share above it’s doesn’t change the gdm resolution.

May be the current gdm version are already run with wayland by default.