F31 won't run from Live USB

Having been running Fedora for ten years without too much trouble I can’t get Fedora 31 to run, even from a Live USB. Hope I’ve supplied enough information for somebody to know why; if more needed please ask.

History :-

Upgraded from F30 to F31 using dnf and desktop PC wouldn’t boot
Reverted to F30 having found an iso on internet
(Why aren’t old but live isos available on Fedora site)

The Problem :-

Created Live F31 USB – (it does run on other computers)
It won’t run on desktop PC
I assume there must be some sort of hardware incompatibility

What happens :-

Starts boot
Run “Test this media & start Fedora-Workstation-Live 31”
Options :-
Media check OK
Screen scrolls what is happening – no apparent problems apart from :-
… dracut-pre-pivot[871] Feb 24 10:49:50 | …
[14.437552] … as above … /etc/multipath.conf does not exist, blacklisting all devices.
[14.437846] … as above … You can run “/sbin/mpath.conf –enable” to create
[14.438065] … as above … /etc/multipath.conf . See man mpathconf(8) for more During the output screen resolution changes
Last shown (something like) :-
Started GNOME Display Manager
Started OK Client Server
Started MPT Client Server
Long wait with blank screen
Screen flashes up previous list
Long wait with blank screen
Flashes message saying “Oh no! Something has gone wrong”
Shows “Try Fedora/Install to Hard Drive” screen
No mouse icon but effect can be seen when hovering over options
Click on “Try Fedora”
Displays screen about being able to install to hard drive later

Occasionally responds to Return on keyboard but then appears to go into loop
Blank screen
Flashes two messages
First not displayed long enough to read
Second “Oh no! Something has gone wrong”
Shows “Try Fedora/Install to Hard Drive” screen
No mouse icon but effect can be seen when hovering over options
Displays screen about being able to install to hard drive later
Pressing ESC brings up “Oh no” Something has gone wrong” screen with Log Out option

The Computer :-

Make/Model :- Shuttle SG33G5 – Purchased 2010

~ $ lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
Address sizes: 36 bits physical, 48 bits virtual
CPU(s): 4
Vendor ID: GenuineIntel
CPU family: 6
Model: 23
Model name: Intel(R) Core™2 Quad CPU Q9400 @ 2.66GHz
BogoMIPS: 5338.39
Virtualization: VT-x
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl cpuid aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm pti tpr_shadow vnmi flexpriority dtherm

~ $ lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IH (ICH9DH) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA Controller [IDE mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA Controller [IDE mode] (rev 02)
01:00.0 IDE interface: JMicron Technology Corp. JMB368 IDE controller
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 12)
03:09.0 Network controller: Ralink corp. RT2561/RT61 802.11g PCI
03:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22A IEEE-1394a-2000 Controller (PHY/Link) [iOHCI-Lynx]

~ $ sudo dmidecode -t bios

dmidecode 3.2

Getting SMBIOS data from sysfs.
SMBIOS 2.5 present.

Wrong DMI structures length: 948 bytes announced, only 942 bytes available.
Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
Vendor: Phoenix Technologies, LTD
Version: 6.00 PG
Release Date: 04/25/2008
Address: 0xE0000
Runtime Size: 128 kB
ROM Size: 1024 kB
ISA is supported
PCI is supported
PNP is supported
APM is supported
BIOS is upgradeable
BIOS shadowing is allowed
Boot from CD is supported
Selectable boot is supported
BIOS ROM is socketed
EDD is supported
5.25"/360 kB floppy services are supported (int 13h)
5.25"/1.2 MB floppy services are supported (int 13h)
3.5"/720 kB floppy services are supported (int 13h)
3.5"/2.88 MB floppy services are supported (int 13h)
Print screen service is supported (int 5h)
8042 keyboard services are supported (int 9h)
Serial services are supported (int 14h)
Printer services are supported (int 17h)
CGA/mono video services are supported (int 10h)
ACPI is supported
USB legacy is supported
LS-120 boot is supported
ATAPI Zip drive boot is supported
BIOS boot specification is supported
Targeted content distribution is supported

Invalid entry length (0). DMI table is broken! Stop.

Try booting F31 with basic graphics mode (see options in the GRUB menu just before booting starts). If you were able to boot with basic graphics, perform the installation and run an update. This might be a regression.

1 Like

(Why aren’t old but live isos available on Fedora site)


Created Live F31 USB – (it does run on other computers)

How did you create it?

Make/Model :- Shuttle SG33G5 – Purchased 2010

Looks like the latest firmware is Aug 2008. Double check that, and also check if it’s current with dmesg | grep DMI

Pressing ESC brings up “Oh no” Something has gone wrong” screen with Log Out option

Difficult to say if this is a kernel bug or possibly a compositor bug. It’ll take some process of elimination to figure it out. If you boot with boot parameter nomodeset does it help? This is suboptimal, but if it works, it’ll help understand where the problem could be. The other thing to try is boot with 3 as-in “runlevel 3” login and do a full dnf update which will get you on a more recent kernel and update the compositer. That alone might fix this.

For sure try to get firmware and software up to date first. If that doesn’t help, then try to login using GNOME on Xorg, perhaps is a Wayland related bug. It’s tedious to have to look through the journal for clues but that’s what anyone else would have to do.


Thank you @twohot.

I’ve tried booting in Basic Graphics Mode and it does work but displays “Input Signal Out of Range, Change Settings 1600x900-60Hz”, which isn’t an option in Settings and within not many seconds the monitor goes to sleep. The keyboard doesn’t wake it, although, judging from what it shows when woken, it there seems to response to pressed keys. The only way to wake it is to turn in off and on again, after which it soon goes to sleep again.

Its behavior make me nervous of trying a clean instalation but I may come back to it if I can’t find another solution.

Thank you @chrismurphy. I’ve tried some of the things you suggested but I don’t understand everything.

Good to know old Fedora releases are officially available!

Downloaded F31 Workstation iso and, using F30 Media Writer, created bootable USB.

Output from dmesg | grep DMI
[ 0.000000] DMI: Shuttle Inc SG33/FG33, BIOS 6.00 PG 04/25/2008
[ 0.005147] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[ 18.126015] input: HDA Intel HDMI/DP,pcm=3 as devices/pci0000:00/0000:00:1b.0/sound/card0/input15

Booted F31 Live USB with “nomodeset” - Behaved the same as when booted in Basic Graphic mode - see my reply to @twohot above.

Booted F31 Live USB with “runlevel 3” - Came up with terminal screen login. Could boot in as root and ls showed there was one file - anaconda-ks.cfg.

Not sure what you mean by doing full dnf update as I am running F31 from USB stick. Also don’t understand how to login using GNOME on Xorg.

Haven’t updated the BIOS as this is something I’ve got to find out how to do.

Hope there’s enough here to hint at what might be wrong. I assume that the downloadable iso is updated with the latest amendments so there is an off chance that whatever the problem is might go away - just being hopeful.

I think there are newer firmware. It’s unknown if it might help or not.

You might consider creating a USB stick from an updated ISO. Right now, F31-WORK-x86_64-LIVE-20200224.iso is current.

Keep us posted.

1 Like

@chrismurphy, hope this helps, it does seem to be better.

Ran F31-WORK-x86_64-LIVE-20200224.iso from a stick.

Run normally comes up with the “Oh no!” message and no mouse pointer although the mouse works. “Run/Install” screen comes up and clicking “Run” brings up the “Install Later” which doesn’t react to return key until the mouse has been moved. Then there are two messages, the first about a problem occurring is soon overwritten by the “Oh no!” message which is followed by the “Run/Install” screen again.

Run with “nomodeset” comes up with “Input Signal Out of Range” but mouse works normally. Running Fedora works, although message remains on the screen (suggested settings not available in settings), but the monitor keeps going to sleep and can only be awoken by turning off and on again.

Working on how to update the BIOS.

If you can put up ‘journalctl -b -o short-monotonic’ somewhere it might give hints what the problem is.

If this is short, paste it inside of message, between the

I’m afraid it isn’t short - 439kB, 4000 lines of text

Debian’s paste;  change “Expiration” to “90d”, it should suffice.
(Aside the manual paste, there is a “Choose File” button).

You can also use

journalctl -b -o short-monotonic | fpaste

– but the maximum expiration for this one is just one day, which is quite short. Still it’s very convenient to quickly share something – especially from the cli.

1 Like

Thank-you for all your knowledge on how to send files - lots to learn!

journalctl output now in debian pastebin split into four sections :


Hope something interesting can be found in it.

The journal now up on debian pastebin as four files - paste.debian.net/1133274 to 7/

I thought the red lines may be of interest so I have extracted them, with the three lines either side, from another boot :

[ 14.349819] localhost audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=initrd-cleanup comm=“systemd” exe=“/usr/lib/systemd/systemd” hostname=? addr=? term>
[ 14.349892] localhost audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=initrd-cleanup comm=“systemd” exe=“/usr/lib/systemd/systemd” hostname=? addr=? termi>
[ 14.352135] localhost iscsid[851]: iSCSI daemon with pid=852 started!
[ 14.352367] localhost iscsid[851]: can’t open InitiatorName configuration file /etc/iscsi/initiatorname.iscsi
[ 14.352404] localhost iscsid[851]: Warning: InitiatorName file /etc/iscsi/initiatorname.iscsi does not exist or does not contain a properly formatted InitiatorName. If using software iscsi (iscs>
[ 14.352440] localhost iscsid[851]: can’t open InitiatorAlias configuration file /etc/iscsi/initiatorname.iscsi
[ 14.352472] localhost iscsid[851]: iscsid shutting down.
[ 14.356446] localhost systemd[1]: iscsid.service: Succeeded.
[ 14.356735] localhost systemd[1]: Stopped Open-iSCSI.

[ 24.067334] localhost kernel: audit: type=1305 audit(1583267621.919:72): op=set audit_pid=2114 old=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:auditd_t:s0 res=1
[ 24.159926] localhost auditd[2114]: Init complete, auditd 3.0 listening for events (startup state enable)
[ 24.235073] localhost kernel: Rounding down aligned max_sectors from 4294967295 to 4294967288
[ 24.235489] localhost kernel: db_root: cannot open: /etc/target
[ 24.295342] localhost kernel: iscsi: registered transport (iser)
[ 24.497794] localhost kernel: RPC: Registered rdma transport module.
[ 24.497879] localhost kernel: RPC: Registered rdma backchannel transport module.

[ 26.627862] localhost audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=avahi-daemon comm=“systemd” exe=“/usr/lib/systemd/systemd” hos>
[ 26.627988] localhost avahi-daemon[2182]: Successfully called chroot().
[ 26.628057] localhost avahi-daemon[2182]: Successfully dropped remaining capabilities.
[ 26.628117] localhost avahi-daemon[2234]: chroot.c: open() failed: No such file or directory
[ 26.628514] localhost avahi-daemon[2182]: Failed to open /etc/resolv.conf: Invalid argument
[ 26.632070] localhost rngd[2188]: Entropy Generation is slow, consider tuning/adding sources
[ 26.638260] localhost rngd[2188]: Entropy Generation is slow, consider tuning/adding sources

[ 49.174029] localhost-live systemd[2579]: Started Signal initialization done to GNOME Session Manager.
[ 49.199618] localhost-live systemd[2579]: gnome-launched-spice-vdagent.desktop-3051.scope: Failed to add PIDs to scope’s control group: No such process
[ 49.199843] localhost-live systemd[2579]: gnome-launched-spice-vdagent.desktop-3051.scope: Failed with result ‘resources’.
[ 49.201136] localhost-live systemd[2579]: Failed to start Application launched by gnome-session-binary.
[ 49.201578] localhost-live systemd[2579]: Started GNOME Accessibility settings.
[ 49.201767] localhost-live systemd[2579]: Reached target GNOME Accessibility settings.
[ 49.380617] localhost-live systemd[2579]: Starting Tracker metadata database store and lookup manager…

[ 99.099150] localhost-live kernel: sd 7:0:0:0: [sdc] 32466944 512-byte logical blocks: (16.6 GB/15.5 GiB)
[ 99.099770] localhost-live kernel: sd 7:0:0:0: [sdc] Write Protect is off
[ 99.099773] localhost-live kernel: sd 7:0:0:0: [sdc] Mode Sense: 03 00 00 00
[ 99.100958] localhost-live kernel: sd 7:0:0:0: [sdc] No Caching mode page found
[ 99.100963] localhost-live kernel: sd 7:0:0:0: [sdc] Assuming drive cache: write through
[ 99.237118] localhost-live systemd[2579]: dbus-:1.2-org.gnome.Boxes.SearchProvider@0.service: Succeeded.
[ 99.626894] localhost-live systemd[2579]: dbus-:1.2-org.gnome.clocks@0.service: Succeeded.
[ 99.693244] localhost-live systemd[2579]: gnome-terminal-server.service: Succeeded.

[ 177.386181] localhost-live grub2-set-bootflag[3751]: Error canonicalizing /boot/grub2/grubenv filename: No such file or directory
[ 177.387208] localhost-live systemd[2579]: grub-boot-success.service: Main process exited, code=exited, status=1/FAILURE
[ 177.387730] localhost-live systemd[2579]: grub-boot-success.service: Failed with result ‘exit-code’.
[ 177.388334] localhost-live systemd[2579]: Failed to start Mark boot as successful.
[ 177.420463] localhost-live gnome-shell[2878]: # _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ‘gio-vfs’
[ 177.488035] localhost-live gnome-shell[2878]: # _g_io_module_get_default: Found default implementation dconf (DConfSettingsBackend) for ‘gsettings-backend’
[ 177.488035] localhost-live gnome-shell[2878]: # watch_fast: “/org/gnome/terminal/legacy/” (establishing: 0, active: 0)

I think it starts with Xorg instead of Wayland because of nomodeset (?) but I’m not sure. There are many gdm-x-session entries,

And then this:

[   43.524566] localhost-live gnome-session-binary[2864]: WARNING: App 'liveinst-setup.desktop' exited with code 1
[   43.525022] localhost-live gnome-session[2864]: gnome-session-binary[2864]: WARNING: App 'liveinst-setup.desktop' exited with code 1

Followed by a bunch of stack traces from GNOME Shell itself

[   84.920973] localhost-live gnome-shell[2878]: Object St.BoxLayout (0x55f6522ced60), has been already deallocated — impossible to access it. This might be caused by the object having been destroyed from C code using something such as destroy(), dispose(), or remove() vfuncs.

So you’ve got at least two bugs. Failure of the video driver, and then failure of the fallback. Troubleshooting video problems can be tedious. Maybe someone on here can help. If not, my usual strategy is to search outside of Fedora, with upstreams and see if the problem has already been reported there. Start by the specific CPU/GPU you have (I can’t tell if this is i915, AMD, or Nvidia, graphics since it’s nomodeset) and then next you’ll actually want to troubleshoot this without nomodeset, because that’s supposed to work.

It sounds to me like there’s been a regression, since this used to work. It’ll take some work to find out what’s failing and why; it’s completely reasonable to just give up and use another distribution if it works there. But it’s possible you’re the first to run into the regression, and it helps make upstream and all their downstreams, including Fedora, better if you are willing to do the troubleshooting work.

Try to boot without nomodeset, which of course won’t work, but you can use boot parameter systemd.debug-shell=1 and maybe you can switch to tty9 to get to a shell (root, no password required) and extract a complete journal, and find a hint there what’s wrong - is it a gnome-shell bug, a mutter bug, a kernel (video driver) bug?

If that doesn’t work, try DVD/netinstall. That uses the metacity instead of mutter. Does it also have the problem? If so, chances are this is a kernel regression. If it works, then maybe it’s a mutter or gnome-shell bug. The other thing is that netinstaller can be booted with parameter inst.sshd which will start sshd, and you can remotely login as root without a passwd. Trick is to find out what IP address to point to. But if you figure it out, you can at least extract the journal to get an idea what’s wrong.

Sorry it’s kinda long and verbose.


@chrismurphy - don’t worry about being long and verbose, we are outside an area I know anything about so explanations are needed!

I’ve looked through the journalctl output after booting with “runlevel 3” and there isn’t any mention of “AMD” or “Nvidia”, but there is of i915.

kernal: pci 0000:00:00.0: detected gtt size: 524288K total, b262144K mappable
kernel: pci 0000:00:00.0: detected 8192K stolen memory
kernel: i915 0000:00:02.0: vgaarb: deactivate vga console
kernel: Console: switching to colour dummy device 80x25
kernel: [drm] Supports vblank timestamp caching Rev2 (21.10.2013).
kernel: [drm] Driver supports precise vblank timestamp query.
kernel: i915 0000:00:02.0: vgaarb: changed VGA decodes: oldddecodes=io+mem,decodes=io+mem:owns=io+mem
kernel: snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC888: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
kernel: snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)

    (26 lines)

kernel: [drm] Initialized overlay support.
kernel: ieee80211 phy0: rt2x00_set_chip: Info - Chipset detected - rt: 2561, rf:0003, rev: 000c
kernel: [drm] Initiatized i915 1.6.0 20191101 for 0000:00:02.0 bon minor 0
system[1]: Starting Load/Save RF Kill Switch Status...
kernel: ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
kernel: fbcon: i915drmfb (fb0) is primary device
systemd-udevd[947]: Using default interface naming scheme 'v243'.
kernel: Console: switching to colour frame buffer device 200x56
systemend-udevd[947]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
kernal: rt61pci 0000:03:09.0 wlp3s9: renamed from wlan0
kernel: i915 0000:00:02.0: fb0: i915drmfb frame buffer device
wireless[1039]: Could not determine country!  Unable to set regulatory domain.

Life would be easier if I could write the journalctl output to disc but I haven’t been able to find out how to access either the hard disc or USB stick - which the system does acknowledge exists when plugged in. Is it possible?

You’ll need to mount them first, and as you’re in a cli environment, you’ll need to do it manually.

Let’s take USB flash drive as an example.

To make an example less cluttered with details we’ll make all the actions as root – to avoid confusion with file ownership and permissions. While it’s a bad idea in general, it’s a bit less inappropriate when you’re trying to troubleshoot/recover something from cli. But: please be really careful with what you write to and delete from your usb flash drive, it’s really easy to overwrite or delete something you need this way.

You can do it properly by giving your restricted user write permission just to the files you need – but I don’t remember the mount options you’ll need from the top of my head ) If someone will provide the commands for a more secure way of doing this – I welcome the suggestions )) I’ll tell just the basics.

So, we’ll become root now:

sudo -i

If you’re doing this from Live USB, sudo password is empty (just press [Enter]). Otherwise you’ll need your user’s password – as you know, of course.

First step would be to make a directory to be a so called mountpoint – it’s where we will mount our drive to. I’ll make it under ‘/media’, another popular folder for this is ‘/mnt’:

mkdir -v /media/myflashdrive

-v is there just to give you some visual feedback that all went as expected.

Step 2 will be to plug in your USB drive and find out which device file/designation it got (sda, sdb, sdc, etc.).

The most common advice on how to see it is to use

dmesg | tail

You should get something like

[298977.886946] usbcore: registered new interface driver uas
[298978.981445] scsi 6:0:0:0: Direct-Access     Kingston DataTraveler 2.0 PMAP PQ: 0 ANSI: 6
[298979.711744]  sdd: sdd1
[298979.728689] sd 6:0:0:0: [sdd] Attached SCSI removable disk

Clearly my flash drive got registered as sdd here, and there’s a hint that it has one partition: sdd1.

Another advice I’ve heard is to look at output of


You’ll get a clean tree-like view of all the drives/partitions on you system, which is quite easy to read/understand. For our specific purpose it lacks clear indication that the drive in question is a USB drive. Still you can. for example, first run it without USB drive plugged in, then again after plugging it in – and compare the results. And it’s a good generic command to get a quick overview of drives/partitions on you system.

So, we know that my flash drive is sdd, and it has a partition named sdd1.

Now (at last!) we can mount it with

mount -v /dev/sdd1 /media/myflashdrive

Now you can go there with

cd /media/myflashdrive

and do what you need with it – being very careful as you’re doing it all as root.

If you want a more graphical way of working with your files from cli, you can use Midnight Commander (do you remember Norton Commander from old MS-DOS times?):

sudo dnf install mc

It can be done from a Live USB – if you have an Internet connection. The easiest way (in cli) would be to plug ethernet cable to your computer/notebook.

After you’re done with writing to you flashdrive, it’s a good idea to unmount it:

cd # to "exit" from you flash drive -- to your home directory.
umount -c /media/myflashdrive

You won’t be able to unmount a drive if you’re in one of it’s subfolders (drive is busy), hence you’ll need to cd “out of it” first.

One more thing. If your native language isn’t English and you have files/folders named in your native language on your flashdrive – and depending on a filesystem type you have on your flashdrive – you’ll need some additional parameters for your files/folders to be displayed correctly.

In my case with fat32 filesystem on my flashdrive -o utf8 helps:

mount -v -o utf8 /dev/sdd1 /media/myflashdrive

And here’s an example of proper mount command for non-root user (I’ve peeked at how Gnome/udisks2 does it to get all this fancy options):

mount -v -o utf8,rw,uid=1000,gid=1000 /dev/sdd1 /media/myflashdrive
  • rw is for forcing mounting with write access (which is actually the default unless filesystem is damaged),
  • uid and gid is a user/group identifier for your current user (usually, 1000 for the first user in the system, 1001 --for the second, etc.),

You can mount your internal drives/partitions in a similar fashion – and if they’re ext4 or other proper linux filesystem (as they usually are) – you won’t need some fancy mount options to work with them properly – even as non-root user. Still you have to keep in mind file ownership and permissions )


Brilliant @nightromantic. Everything I needed to know, and more - and a mention of DOS!

1 Like

I don’t know if it is any use but I have now pasted journalctl output for “runlevel 3”.


There are 15 references to things failing but I don’t have any idea if any of them are indications of a fatal error, or just something not going as it might be expected to.

Journalctl for systemd.debug-shell=1. Lots of failures. How many years does it take to understand what it all means?