External monitor not working on fedora 31

Reading your post and seeing that you have a intel CPU and nvidia is possible that you do have a hybrid CPU+GPU integreted (check if you cpu have a internal GPU, it look be so because the module i915 is loaded, but you would check if it is the case to be sure, maybe the module is loaded by default in the intel CPU within/without integreted i am not sure because i use amd ) which should do that you was in the case of optimus and so if you install the driver from rpm fusion you should check it:

https://rpmfusion.org/Howto/Optimus#External_Monitors_detection

External Monitors detection

At this time, external monitors connected to the NVIDIA GPU requires the PrimaryGPU option to be set. See the next topic about how to setup as appropriate.

NVIDIA PrimaryGPU Support

Before the Full optimus support, the only way to enable the NVIDIA driver was to set the NVIDIA GPU to be used by default. To recover this previous behaviour, you can use:

cp -p /usr/share/X11/xorg.conf.d/nvidia.conf /etc/X11/xorg.conf.d/nvidia.conf

And edit the file to use: Option “PrimaryGPU” “yes”

Like this user did too:

I hope this can help you a bit.

Regards.

3 Likes