External display over USB-C issue with HP elite dock G4 | Fedora 40

Hello everyone,
Another docking station related issue post.
I have read all the problems available here concerning the additional monitor connected through the docking station, unfortunately nothing works for me :frowning:
As you can see on screen below my monitor is recognized, but its black all time.


I tried changing the resolution and the refresh rate, but nothing helps. my monitor remains black as it was before.
If I connect the monitor directly to the hdmi port on the laptop, everything works as it should, so it’s probably a problem with the docking station

Here is my hardware probe with some logs:

Output of Inxi -Fzxx

System:
  Kernel: 6.8.9-300.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-34.fc40
  Desktop: GNOME v: 46.1 tk: GTK v: 3.24.41 wm: gnome-shell dm: GDM
    Distro: Fedora Linux 40 (Workstation Edition)
Machine:
  Type: Laptop System: ASUSTeK product: Vivobook_ASUSLaptop X3400PA_K3400PA
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: X3400PA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: X3400PA.302 date: 09/29/2022
Battery:
  ID-1: BAT0 charge: 50.8 Wh (98.4%) condition: 51.6/63.0 Wh (81.8%)
    volts: 12.0 min: 12.0 model: ASUSTeK ASUS Battery serial: N/A
    status: charging
CPU:
  Info: quad core model: 11th Gen Intel Core i5-11300H bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 320 KiB L2: 5 MiB L3: 8 MiB
  Speed (MHz): avg: 1441 high: 3494 min/max: 400/4400 cores: 1: 3494 2: 400
    3: 2770 4: 400 5: 1826 6: 1839 7: 400 8: 400 bogomips: 49766
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-12.1 ports: active: DP-3,eDP-1 empty: DP-1,
    DP-2, DP-4, DP-5, DP-6, HDMI-A-1 bus-ID: 0000:00:02.0 chip-ID: 8086:9a49
  Device-2: Quanta USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 3-6:3 chip-ID: 0408:30e1
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 23.2.6
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: :1 screens: 1
  Screen-1: 0 s-res: 6320x1800 s-dpi: 96
  Monitor-1: DP-3 mapped: DP-1-1 pos: right model: Dell S3422DW
    res: 3440x1440 dpi: 110 diag: 864mm (34")
  Monitor-2: eDP-1 pos: primary,left model: Samsung 0x4171 res: 2880x1800
    dpi: 242 diag: 356mm (14")
  API: OpenGL v: 4.6 vendor: intel mesa v: 24.0.6 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: Mesa Intel Xe Graphics (TGL GT2)
    device-ID: 8086:9a49
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 0000:00:1f.3 chip-ID: 8086:a0c8
  Device-2: Realtek USB Audio driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-2.1.3:12
    chip-ID: 0bda:482a
  API: ALSA v: k6.8.9-300.fc40.x86_64 status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 0000:00:14.3
    chip-ID: 8086:a0f0
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
    rev: 3.0 speed: 5 Gb/s lanes: 1 bus-ID: 2-1.2:44 chip-ID: 0bda:8153
  IF: enp0s13f0u1u2 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 3-10:6 chip-ID: 8087:0026
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.2
    lmp-v: 11
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b
Drives:
  Local Storage: total: 476.94 GiB used: 6.89 GiB (1.4%)
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNU512GZ size: 476.94 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 34.9 C
Partition:
  ID-1: / size: 475.35 GiB used: 6.58 GiB (1.4%) fs: btrfs dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 301.9 MiB (31.0%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 19 MiB (3.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 475.35 GiB used: 6.58 GiB (1.4%) fs: btrfs
    dev: /dev/nvme0n1p3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 55.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB note: est. available: 15.31 GiB used: 3.49 GiB (22.8%)
  Processes: 359 Power: uptime: 54m wakeups: 1 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 14 Compilers: gcc: 14.0.1 Shell: Bash
    v: 5.2.26 running-in: gnome-terminal inxi: 3.3.34

Thanks for answers!

What is the output of boltctl ? Please paster it here in </> preformatted text.

It should be HP Thunderbolt Dock G2

p040@fedora-2:~$ boltctl
p040@fedora-2:~$ boltctl list
p040@fedora-2:~$ 

hmm weird, im not getting listed my dock. Any ideas?

If you want to try adding this repo to add DisplayLink and see if it helps, that’s one thing. . .

dnf config-manager --add-repo=https://negativo17.org/repos/fedora-multimedia.repo && dnf install -y displaylink

Unfortunately it doesn’t help, I already tried to install this repo, because I saw your answers in another post.

Here is what i did:

Unplug everything from dock, connected the dock to thunderbolt port and reboot - nothing changes. boltctl is empty.

Plug in usb dongles from keyboard and mouse and reboot - working mouse and keyboard(They have worked before). boltctl is empty.

Finally, plug in hdmi to dock with dongles and reboot - mouse and keyboard works, monitor detected, but black all time. boltctl is empty.

It is worth noting that on the same setup with widnows 11 everything ran as expected :frowning:

1 Like

It really does not matter. edited my post last night before I put the repo comment. Apparently the G4 is poorly supported for many devices. I found some lists where it’s simply incompatible with many laptops. Some people have managed to get it to work, there was a Linux Mint thread where the Dock worked. No information on what was used to make it work though.

I’ll keep digging around, and post an update if I see any relevant finds.

1 Like