Extended Smart Hide Blinking

The laptop (DELL XPS 9350) is installed with fedora 37 gnome43. When using the intelligent hide of the extension, the problem will occur: the hide is normal when the software is windowed, and the mouse pressure can normally unhide and display normally, but after the software is maximized, the mouse slides back and forth and flickers (switch back and forth between hide and display). The above problems occur in the plug-in: dash to dock and hide top bar

Can you please make a inxi -Fzx and paste it here as pre-formatted </> text.
So we can assist better.

Is your system up to date? Have you installed all the necessary firmware?

  Kernel: 6.1.7-200.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-25.fc37 Console: pty pts/0 Distro: Fedora release 37 (Thirty Seven)
  Type: Laptop System: Dell product: XPS 13 9350 v: N/A serial: <filter>
  Mobo: Dell model: 0JXC1H v: X00 serial: <filter> UEFI: Dell v: 1.13.0
    date: 02/10/2020
  ID-1: BAT0 charge: 52.7 Wh (100.0%) condition: 52.7/52.7 Wh (100.0%)
    volts: 8.5 min: 7.6 model: SMP DELL RWT1R43 status: full
  Info: dual core model: Intel Core i7-6560U bits: 64 type: MT MCP
    arch: Skylake rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 4 MiB
  Speed (MHz): avg: 2925 high: 3202 min/max: 400/3200 cores: 1: 2200 2: 3202
    3: 3197 4: 3101 bogomips: 17599
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Iris Graphics 540 vendor: Dell driver: i915 v: kernel
    arch: Gen-9 bus-ID: 00:02.0
  Device-2: Microdia Integrated Webcam HD type: USB driver: uvcvideo
    bus-ID: 1-5:3
  Display: server: X.org v: 1.20.14 with: Xwayland v: 22.1.7 driver:
    gpu: i915 note: X driver n/a resolution: 1920x1080
  API: OpenGL Message: GL data unavailable for root.
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3
  Sound API: ALSA v: k6.1.7-200.fc37.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.64 running: yes
  Device-1: Broadcom BCM4350 802.11ac Wireless Network Adapter vendor: Dell
    driver: brcmfmac v: kernel bus-ID: 3a:00.0
  IF: wlp58s0 state: up mac: <filter>
  Device-1: Broadcom BCM2045A0 type: USB driver: btusb v: 0.8 bus-ID: 1-3:2
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 238.47 GiB used: 14.02 GiB (5.9%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM951 NVMe 256GB
    size: 238.47 GiB temp: 30.9 C
  ID-1: / size: 236.89 GiB used: 13.74 GiB (5.8%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 271.9 MiB (27.9%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 236.89 GiB used: 13.74 GiB (5.8%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: zram size: 7.61 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 45.0 C pch: 43.5 C mobo: 33.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 0
  Processes: 288 Uptime: 6m Memory: 7.61 GiB used: 2.48 GiB (32.6%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.2.1 Packages: 2
  note: see --rpm Shell: Bash v: 5.2.15 inxi: 3.3.24
  1. Same problem with Wayland? Looks like you use X11.

  2. Can you please check if you get the same error with deactivated “hide top bar” extension?

  1. Wayland is used now
  2. Plug-ins can work normally for software (such as edge) (intelligent hiding), but after the software uses full-screen maximization, the two intelligent hidden plug-ins will have the same problem, so it is ruled out that the problem is a single plug-in.
  3. It is suspected that it is a system-driven problem. Is there a solution?

I can not reproduce … use same dash to dock and hide top bar.
Do you have a other frequency you can test with your display resolution (1920x1080)?

Must be something with your GPU?!

I suspect the GPU driver is the same as you, but I don’t know how to reinstall or update the driver.

no mine is Intel 3rd Gen Core processor Graphics driver: i915 v: kernel

You use a kernel driver as I do. So if your firmware is up to date you should get recognized the right GPU.

Try this in terminal:

sudo fwupdmgr update

I really want to find the problem, but there is still no solution: I try to use the screen recording function to record this problem. During the screen recording process, the software is still flashing after maximizing, but the screen recording result is really normal. I understand that it may be a laptop display problem? Or refresh rate

Yes that’s why i asked you. Did you check if you have a alternative refresh rate in the display settings?

I tried, but I couldn’t change it in my notebook refresh. It can only be maintained at 59.93Hz

I found the reason. The hide top bar extension is the culprit. After I tried to disable this extension, the dash to dock can be hidden normally and does not flash when the software is maximized. I plan to submit this bug on the website of hide top bar.