"Ethernet" showing unplugged Fedora 31

Hello all! New here, I’ve worked with Linux Distros in the past, particularly during college, but this is my first time booting linux along side windows 10. Most of the time I would just use a VM. Yesterday I successfully installed Fedora 31 Server, was able to make my way to installed the GNOME desktop, and was trying to install FireFox when I noticed that I was not receiving a Internet connection. Upon digging into it, it was showing that I had a network connection, but the cable was unplugged. I tried a new cable, tried reading multiple forums and trying many different commands in the kernel, which is where one of the commands that someone was recommending deleted the NIC completely, and me not being very familiar with linux, was unsure how to add it back, and couldn’t find any help on how to add it back. Today, I wiped the partition of the drive that contained the Fedora install and have started fresh. In the installation process, I looked into the network settings, and the ethernet connection is showing unplugged. I’ve tried configuring it with a static IP, and even tried using a USB to Gigabit adapter, and neither are working.

Any advice or help given would be greatly appreciated!


Yes I tried good cables and still didn’t fix it. I finally booted windows and updated the drivers for everything and then installed Fedora and it seems to be working so far.