Espanso COPR available for testing

Following this post, I’m announcing that packages for #Espanso are available on copr for #Fedora:

How to install:

sudo dnf copr enable eclipseo/espanso
sudo dnf copr install espanso espanso-wayland

For wayland, you have to run first after install:

sudo setcap "cap_dac_override+p" $(which espanso-wayland)

to allow espanso-wayland to grab the keys.

1 Like

Exciting! I looked at it a long time ago and IIRC Wayland support was lacking at the time.

Will give this a try after the Labor Day weekend. Do you need help getting the pieces into Fedora?

1 Like

Can this be done in %postinstall?

maybe, I need to brush up on how postinstall macros work.

You can basically run anything there after the RPM is installed (preferably not too much). There is also %posttrans that comes after the RPM transaction is done.

Hmm actually, any reason this can’t be done at the end of %install?

1 Like

An old post here has examples, might be worth trying to see if they still work

1 Like

Hello, I’ve been using Espanso on Slackware and Void Linux before moving to Silverblue and UBlue. Apologies if this is the wrong place to post this, but here are the steps I followed,

  1. Downloaded the repo file from
  2. Added it to /etc/yum.repos.d
  3. Installed it as rpm-ostree install espanso-wayland.
  4. Now I am able to follow the guide to enable espanso-wayland as a systemd service and it launches.

However, I still have the following issues,

  1. I am unable to use setcap as indicated,
    sudo setcap "cap_dac_override+p" $(which espanso-wayland) I get the error Failed to set capabilities on file /usr/bin/espanso-wayland' (Read-only file system)
  2. A window/process that I am unable to dismiss is created. If I kill it with ps -ef | grep ‘espanso-wayland’ and then kill, then it doesn’t run at all. Here is a video for it.
    Screencast from 2023-09-11 22-54-38.webm

I have posted this issue on Ublue’s Github at Requesting Espanso · Issue #454 · ublue-os/bluefin · GitHub.

The suggestion there was to do a “PR in the copr and enable the package and then probably fix the issues you ran into.”

If there are any suggestions on how to go about this, please do let me know and I’d be happy to contribute.

@eclipseo Can you let me know if you need any help with this issue?