Errors upgrading from F31 to F32

Finally a relevant thread. I’m also having this issue.

really don’t want to invest in a fresh install on the machine I’m working on. still my main linux machine.

So getting all the same issues as above. Stuck at 0% and timeouts.
Weird thing is if I do upgrade via softwarecenter instead of the CLI, I get to 26% and basicaly the same error (-cacheonly error).

anyway… so back to CLI updating.

I mainly deleted outdated python2 and wine* packages and after couple of sytem-upgrade tries eventually decided also to deleted all i686 packages.

disabled all repos except fedora and updates

still the 0% problem…
/var/log/dnf.log keeps adding packages that are ‘faulty’

eventually found out I had some el7 packages. removed those, and then finaly it started upgrading and reboot still stuck at 0% and failes to system-upgrade
so no progress yet. my dnf.log always looks like this:

CRITICAL Error: Some packages have invalid cache, but cannot be downloaded due to “–cacheonly” option

everytime it’s another inimportant packages from the updates repo, i delete it (can always install later again). do the whole reoutine again: system-upgrade clean, dnf clean all, dnf update, dnf upgrade --refresh, system-upgrade download --refresh --releasever=32, sytem-upgrade reboot
keeps hanging at 0% and keeps adding the same error in dnf.log, just different packages. I kept deleting those non-vital packages until I hit this:

Transaction Summary

Install 63 Packages
Upgrade 2860 Packages
Remove 5 Packages
Downgrade 3 Packages

2020-07-02T21:01:12Z DEBUG systemd-245.6-2.fc32.x86_64: sha256 check failed: 83d20d0681cdddfe2b19e236ca5a15248ca503d27ea326b1c4521a8ab943ddf8 vs edde21d3251b50f0c63eda51d1b7fa8775e2db42fe58f5d418cbff4910a35550
2020-07-02T21:01:21Z INFO Total size: 2.7 G
2020-07-02T21:01:21Z INFO Total download size: 4.2 M
2020-07-02T21:01:21Z INFO Downloading Packages:
2020-07-02T21:01:26Z DEBUG systemd-245.6-2.fc32.x86_64: sha256 check failed: 8f8e4dce350f0ee9195eacd690ba54889dd80746339bb71f5400970d5247e67e vs edde21d3251b50f0c63eda51d1b7fa8775e2db42fe58f5d418cbff4910a35550
2020-07-02T21:01:26Z CRITICAL Package “systemd-245.6-2.fc32.x86_64” from repository “updates” has incorrect checksum
2020-07-02T21:01:32Z DDEBUG Cleaning up.
2020-07-02T21:01:32Z SUBDEBUG
Traceback (most recent call last):
File “/usr/lib/python3.7/site-packages/dnf/cli/”, line 67, in main
return _main(base, args, cli_class, option_parser_class)
File “/usr/lib/python3.7/site-packages/dnf/cli/”, line 106, in _main
return cli_run(cli, base)
File “/usr/lib/python3.7/site-packages/dnf/cli/”, line 130, in cli_run
ret = resolving(cli, base)
File “/usr/lib/python3.7/site-packages/dnf/cli/”, line 176, in resolving
File “/usr/lib/python3.7/site-packages/dnf/cli/”, line 226, in do_transaction
self.download_packages(install_pkgs, self.output.progress, total_cb)
File “/usr/lib/python3.7/site-packages/dnf/”, line 1137, in download_packages
remote_pkgs, local_pkgs = self._select_remote_pkgs(pkglist)
File “/usr/lib/python3.7/site-packages/dnf/”, line 2519, in _select_remote_pkgs
_('Some packages have invalid cache, but cannot be downloaded due to ’
dnf.exceptions.Error: Some packages have invalid cache, but cannot be downloaded due to “–cacheonly” option
2020-07-02T21:01:32Z CRITICAL Error: Some packages have invalid cache, but cannot be downloaded due to “–cacheonly” option

Let’s not delete that one… :sweat_smile:
any idea how to proceed further?

1 Like

Hi @dddw, welcome to the community. Please take a minute to go through the posts in the #start-here category if you’ve not yet had a chance.

I’ve moved your query to a new topic since the other one was solved but that solution doesn’t seem to have worked for you.

Can you please provide some more information: what part of the upgrade is this stuck at? At what command? Is this the download step or the upgrade on reboot step? I.e. 3 or 5 from here?

it may be because you delete python2

No, that shouldn’t cause any issues. Fedora moved to Python 3 and removing Python 2 packages should not affect the system in general.

Hey thanks for the warm welcome.
Longtime Fedora user (since version 23 I believe), and like it because it’s on the edge of new things, but does keep things pretty darn stable.
Good question @FranciscoD . I indeed went through all steps, so definitly part 5 is where it fails. (stuck at 0% for a while and then reboots again into normal boot)
Tried --allowerasing , i.c.w. ‘–best’ and also specifiying the releaseversion as well. All to no avail.

Python2 also was listed as being sheduled to be deleted, so I thought deleting them might help the process.

other things I checked:
disabled SELinux (was targeted before)
remove all dnf.conf settings (tried zchunk=off). still get the same errors

tried manually import releasekey of version 32 just in case as done with rawhide.
Also I deleted now everything I could find was installed manually via rpm installs and loose rpm package installs, also all fedy and flatpak packages.
still same errors.
This isn’t a fresh install, I upgraded it from from at least version 29 before I believe…
Now dnf gets cacheerrors on backgrounds, fonts (which I deleted, however I doubt that could be the cause)
Have no idea how to proceed further :expressionless:

So how to continue debugging this?

so I moved to Silverblue… how that fixes some of my upgrade issues in the future.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.