Errors during downloading metadata for repository 'amdgpu':

First I want to say that I was very excited after installing fedora 35 and it said my graphics card was an AMD Radeon rx 6700 xt. I had been screwing with Ubuntu for 2 weeks and kept loosing the card. anyways thats where the excitement ends. I would like CLInfo to say I have 1 device, but its 0. i tried to install amdgpu:
sudo amdgpu-install --opencl=legacy

AMDGPU 21.40.2 repository 549 B/s | 178 B 00:00
Errors during downloading metadata for repository ‘amdgpu’:

Ignoring repositories: amdgpu, amdgpu-proprietary
Last metadata expiration check: 0:00:01 ago on Thu 27 Jan 2022 06:52:10 PM CST.
No match for argument: amdgpu-lib
No match for argument: amdgpu-dkms
No match for argument: clinfo-amdgpu-pro
No match for argument: opencl-orca-amdgpu-pro-icd
Error: Unable to find a match: amdgpu-lib amdgpu-dkms clinfo-amdgpu-pro opencl-orca-amdgpu-pro-icd

$ clinfo
Number of platforms 0
I tried installing Radion Profile, but it comes up empty.

Which repos do you have enabled?
Post the output of dnf repolist please.

dnf repolist
repo id                         repo name
amdgpu                          AMDGPU 21.40.2 repository
amdgpu-proprietary              AMDGPU 21.40.2 Proprietary repository
fedora                          Fedora 35 - x86_64
fedora-cisco-openh264           Fedora 35 openh264 (From Cisco) - x86_64
fedora-modular                  Fedora Modular 35 - x86_64
google-chrome                   google-chrome
phracek-PyCharm                 Copr repo for PyCharm owned by phracek
rocm                            ROCm 4.5.2 repository
rpmfusion-nonfree-nvidia-driver RPM Fusion for Fedora 35 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam         RPM Fusion for Fedora 35 - Nonfree - Steam
teamviewer                      TeamViewer - x86_64
updates                         Fedora 35 - x86_64 - Updates
updates-modular                 Fedora Modular 35 - x86_64 - Updates

I added the </> Preformatted text tags to your post above so it is a lot more readable. Please use those tags yourself in the future.

If those 2 amdgpu repos are fedora compatible, I wonder why you used sudo amdgpu-install --opencl=legacy instead of dnf to attempt installing the desired packages.

Hello @stevemiske ,
Welcome to ask :fedora: . There are a few AMD GPU packages currently in Fedora Linux repo’s, the driver for Xorg … xorg-x11-drv-amdgpu.x86_64 : AMD GPU video driver
… and …
radeontop.x86_64 : AMD Radeon video cards monitoring utility
… and …
rocm-smi.noarch : AMD ROCm System Management Interface (Which I think is performance tuning)
… and …
umr.x86_64 : AMDGPU Userspace Register Debugger
I would try the monitoring utility at first to see what is already installed for your card. Just a suggestion.

If you’re wanting to utilize the amdgpu-pro version of the driver, I’d suggest taking a look at [GUIDE] Install amdgpu-pro OpenCL in Fedora 32

It might need some modifications for for F35.

Real newbie here, I have no Idea where there is a monitor as I do not see something like that installed. I know the driver is installed and being used for video, but I can’t see anything with regard to how it is functioning CLInfo.

Hi, if you get the message as bellow:

[testcase@fedora ~]$ clinfo
Number of platforms                               0

May be you need to install mesa-libOpenCL first.

[rizal@fedora ~]$ clinfo
Number of platforms                               1
  Platform Name                                   Clover
  Platform Vendor                                 Mesa
  Platform Version                                OpenCL 1.1 Mesa 21.3.4
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_icd
  Platform Extensions function suffix             MESA

  Platform Name                                   Clover
Number of devices                                 1
# trimmed
I tried

dnf install mesa-libOpenCL

But now get this error.

Max work group size                             256
fatal error: cannot open file '/usr/lib64/clc/gfx1030-amdgcn-mesa-mesa3d.bc': No such file or directory
  Preferred work group size multiple (kernel)     <getWGsizes:1504: create kernel : error -46>
  Preferred / native vector sizes                 
    char                                                16 / 16      
    short                                                8 / 8       
    int                                                  4 / 4       
    long                                                 2 / 2       
    half                                                 0 / 0        (n/a)
    float                                                4 / 4       
    double                                               2 / 2        (cl_khr_fp64)
  Half-precision Floating-point support           (n/a)
  Single-precision Floating-point support         (core)
    Denormals                                     No
    Infinity and NANs                             Yes
    Round to nearest                              Yes
    Round to zero                                 No
    Round to infinity                             No
    IEEE754-2008 fused multiply-add               No
    Support is emulated in software               No
    Correctly-rounded divide and sqrt operations  No
  Double-precision Floating-point support         (cl_khr_fp64)
    Denormals                                     Yes
    Infinity and NANs                             Yes
    Round to nearest                              Yes
    Round to zero                                 Yes
    Round to infinity                             Yes
    IEEE754-2008 fused multiply-add               Yes
    Support is emulated in software               No
  Address bits                                    64, Little-Endian
  Global memory size                              12884901888 (12GiB)
  Error Correction support                        No
  Max memory allocation                           10307921510 (9.6GiB)
  Unified memory for Host and Device              No
  Minimum alignment for any data type             128 bytes
  Alignment of base address                       32768 bits (4096 bytes)
  Global Memory cache type                        None
  Image support                                   No
  Local memory type                               Local
  Local memory size                               32768 (32KiB)
  Max number of constant args                     16
  Max constant buffer size                        67108864 (64MiB)
  Max size of kernel argument                     1024
  Queue properties                                
    Out-of-order execution                        No
    Profiling                                     Yes
  Profiling timer resolution                      0ns
  Execution capabilities                          
    Run OpenCL kernels                            Yes
    Run native kernels                            No
    ILs with version                              (n/a)
  Built-in kernels with version                   (n/a)
  Device Extensions                               cl_khr_byte_addressable_store cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_int64_base_atomics cl_khr_int64_extended_atomics cl_khr_fp64 cl_khr_extended_versioning
  Device Extensions with Version                  cl_khr_byte_addressable_store                                    0x400000 (1.0.0)
                                                  cl_khr_global_int32_base_atomics                                 0x400000 (1.0.0)
                                                  cl_khr_global_int32_extended_atomics                             0x400000 (1.0.0)
                                                  cl_khr_local_int32_base_atomics                                  0x400000 (1.0.0)
                                                  cl_khr_local_int32_extended_atomics                              0x400000 (1.0.0)
                                                  cl_khr_int64_base_atomics                                        0x400000 (1.0.0)
                                                  cl_khr_int64_extended_atomics                                    0x400000 (1.0.0)
                                                  cl_khr_fp64                                                      0x400000 (1.0.0)
                                                  cl_khr_extended_versioning                                       0x400000 (1.0.0)

NULL platform behavior
  clGetPlatformInfo(NULL, CL_PLATFORM_NAME, ...)  Clover
  clGetDeviceIDs(NULL, CL_DEVICE_TYPE_ALL, ...)   Success [MESA]
  clCreateContext(NULL, ...) [default]            Success [MESA]
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_DEFAULT)  Success (1)
    Platform Name                                 Clover
    Device Name                                   AMD Radeon RX 6700 XT (NAVY_FLOUNDER, DRM 3.42.0, 5.15.16-200.fc35.x86_64, LLVM 13.0.0)
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CPU)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_GPU)  Success (1)
    Platform Name                                 Clover
    Device Name                                   AMD Radeon RX 6700 XT (NAVY_FLOUNDER, DRM 3.42.0, 5.15.16-200.fc35.x86_64, LLVM 13.0.0)
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_ACCELERATOR)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CUSTOM)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_ALL)  Success (1)

and my application that needs it says

PU Health check failed for program build.
GPU Health check failed for create kernel build.
GPU Health check failed for enqueue kernel.
OpenCL driver detected.
Number of OpenCL supported GPUs: 1 
No Cuda driver or GPUs detected. 
Device 0: 
    Name:    AMD Radeon RX 6700 XT (NAVY_FLOUNDER, DRM 3.42.0, 5.15.16-200.fc35.x86_64, LLVM 13.0.0) 
    Address: 4294967295:4294967295 
    Vendor:  Intel(R) Corporation
    Drivers: OpenCL
    Memory:  12288 MByte 
    Active:  false (not selected) 

:thinking: Why there a message about Cuda? Are your system have Nvidia card as hybrid GPU? Or in the past you used Nvidia card and still have Nvidia driver installed?

No nvida, brand new setup, its a amd rx 6700 xt board. it’s just the current problem I am trying to get around

Well I am now contemplating trying Suse, it shouldn’t take an act of god to get a gpu card to work. Ubuntu was the least successful, fedora at least loaded the card at its most Basic level, leaving it to be problems to get amdgpu pro to install. Very frustrated here. I can keep switching OS’s, because there in nothing but the OS and trying to install the card on the machine. Something has to work!

You could try find the package with dnf search clc and there will be some packages offered. Usually (not always) if there a folder under /usr/lib64/<folder>/libfile.something or /lib64/<folder>/libfile.something, the folder name are referring the packages name.

In my system I have libclc installed.

I was giving the actual package names in the Fedora Linux repo’s. So sudo dnf install xorg-x11-drv-amdgpu radeontop. The monitoring package which will tell you if the system “sees” your card correctly is radeontop I assume you would need the driver but maybe try with just the monitoring package first.