Error with rpmfusion-nonfree-nvidia-driver when rebase

after install and update fedora silverblue 30, then install nvidia drivers with
rpm-ostree install kmod-nvidia xorg-x11-drv-nvidia

and try to rebase for fedora 31 image
sudo rpm-ostree rebase fedora:fedora/31/x86_64/silverblue

get this error :v

You’ll probably need to edit /etc/yum.repos.d/rpmfusion-nonfree-nvidia-driver.repo and changed enabled to 0.

I don’t think it that repo has a a F31 brach yet. The main rpmfusion repos do so you can grab the nvidia driver from there.

thx, but before disable the nvidia repo and rebase, have some way to install the driver again on f31?

You could try pre-emptively switching to the main rpm-fusion driver on F30 then rebasing?

what is the main rpmfusion repo?

https://rpmfusion.org/Configuration

yes, i disabled the nvidia repo and switch to rpmfusion and everything works fine :D, but now i have other problem with toolbox, if i can resolve this i will install fedora over the ubuntu on my desktop.

I had the same problem.
I could only solve it with the following method.

# rpm-ostree status > current_base
# rpm-ostree reset
# rpm-ostree rebase fedora:fedora/31/x86_64/silverblue
# rpm-ostree kargs --delete=rd.driver.blacklist=nouveau --delete=modprobe.blacklist=nouveau --delete=nvidia-drm.modeset=1
// reboot
# rpm-ostree install rpmfusion-free-release-31.noarch.rpm rpmfusion-nonfree-release-31.noarch.rpm
// reboot
# rpm-ostree update
// check current_base
# rpm-ostree install <LayeredPackages...>
# rpm-ostree kargs --append=rd.driver.blacklist=nouveau --append=modprobe.blacklist=nouveau --append=nvidia-drm.modeset=1
// reboot

I used the same method to upgrade from silverblue 29 to 30.
I don’t know if it’s the right way.

RPMFusion is a separate project from Fedora. It is not supported by Fedora.