Error while installing gnome-shell-extensions due to missing `unzip` command on a freshly installed system

I just did a fresh installation of fedora 30, I’ve been unable to install any gnome extension (from or from gnome software). Gnome software gave me the error Timeout was reached.

Reading the logs I was able to see an error related to the unzip package

JS ERROR: GLib.SpawnError: Failed to execute child process “unzip” (No such file or directory)

After reading What's this? - GNOME Shell Extensions

Some distributions don’t quite package GNOME correctly. Make sure that you have the unzip package installed.

I tried to check if unzip was installed, it wasn’t, but when I tried to install it with dnf install unzip dnf said that the package was already installed.

I solved the problem by reinstalling the package dnf reinstall unzip.

I’m creating this in case someone else is having the same problem, but I also wonder if this is a bug in the new version of fedora or I missed something? This was a fresh installation of fedora and trying to install an extension after dnf upgrade.

Hello @stsewd. Welcome to the community! Please have a look at the #start-here posts if you’ve not had a chance yet. They summarise useful information on how we can get the best out of this platform.

That is very odd. I’ve not seen this issue before, and it points to errors during the installation process. Did you verify the downloaded image and run the test on the live media before you installed by any chance? That should’ve caught anything unexpected.

Hopefully this is only a one-off thing, though.