Error: Transaction test error | upgrade from F37 to F38


Attempting to upgrade from 37 to 38 but encountering error. Previously set kernel limit to two, but still get the error.

Error: Transaction test error:
  installing package kernel-core-6.2.15-300.fc38.x86_64 needs 18MB more space on the /boot filesystem
  installing package grub2-efi-ia32-1:2.06-95.fc38.x86_64 needs 20MB more space on the /boot filesystem
  installing package grub2-efi-ia32-cdboot-1:2.06-95.fc38.x86_64 needs 20MB more space on the /boot filesystem

Error Summary
Disk Requirements:
   At least 20MB more space needed on the /boot filesystem.

I check the following:

rpm -q kernel; df -h /boot; lsblk -o +FSTYPE,UUID | grep -e /boot

Filesystem      Size  Used Avail Use% Mounted on
/dev/nvme0n1p2  974M  880M   27M  98% /boot
├─nvme0n1p1 259:1    0   600M  0 part /boot/efi   vfat   6A48-0764
├─nvme0n1p2 259:2    0     1G  0 part /boot       ext4   60317848-5193-4534-a690-9d27b12d92d6

Research suggests needing more than 1G for /boot doesn’t sound right. Q1 so what needs fixing if this is the case?

Research to resize /boot is beyond my tech know-how regarding unmounting. I do have 2G available but I have no idea how to give it to /boot. Q2 is resizing /boot possible for a newbie?

As a newbie, it sounds like I have to install and start over. If so, how do I avoid this boot issue again? I previously used the default setup or if I understand correctly without LVM. Q3 I don’t recall but do you choose LVM during install?

Argh, easy updates and upgrades is why I chose over Ubuntu on one hand, and Arch type on the other.

Welcome to Fedora @prexecom

Lets see if there is trash we can remove:

Please do not forget to use </> (see menubar from discourse editor) pre-formated text when pasting information.

sudo du -h /boot in terminal to paste the output here.

sudo ls -ahl /boot in terminal to paste here.


Thank you Ilikelinux

So do I

Below is the first command you asked for. It produce 40,000+

I assume cut and paste version below is enough to get the idea

12K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/opt/chrome
8.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/opt/edge/native-messaging-hosts
12K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/opt/edge
28K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/opt
4.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/udisks2/modules.conf.d
16K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/udisks2
8.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/crypto-policies/local.d
8.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/crypto-policies/back-ends
4.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/crypto-policies/policies/modules
8.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/crypto-policies/policies
12K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/crypto-policies/state
44K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/crypto-policies
4.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/cron.weekly
4.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/kdump/pre.d
4.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/kdump/post.d
12K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/kdump
16K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/unbound
20K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/mcelog/triggers
28K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/mcelog
36K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/alternatives
8.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/cron.d
16K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/libreport/events
64K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/libreport/plugins
88K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/libreport/events.d
20K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/libreport/workflows.d
212K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/libreport
4.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/vulkan/icd.d
4.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/vulkan/explicit_layer.d
4.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/vulkan/implicit_layer.d
16K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/vulkan
24K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/bash_completion.d
84K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/gimp/2.0
88K     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/gimp
4.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/issue.d
4.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/udev/hwdb.d
8.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/udev/rules.d
12M     /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/udev
4.0K    /boot/timeshift/snapshots/2023-04-22_11-58-24/localhost/etc/motd.d

The following /boot/timeshift included the following directories

I saved it if you need to see.  But I didn't notice an attachment feature.

YIKES, the above makes it look like I am a user error. As far as I can tell, I have not activated timeshift and see excluded root settings. Is the next step simply running the following: sudo dnf remove timeshift. Will it remove the above?

As for your second suggestion:

total 260M
dr-xr-xr-x. 7 root root 4.0K May 14 16:24 .
dr-xr-xr-x. 1 root root  182 Apr 30 08:30 ..
-rw-r--r--. 1 root root 250K Apr 30 21:32 config-6.2.14-200.fc37.x86_64
-rw-r--r--. 1 root root 250K May 11 12:14 config-6.2.15-200.fc37.x86_64
drwx------. 4 root root 4.0K Dec 31  1969 efi
drwx------. 3 root root 4.0K May 13 21:55 grub2
-rw-------. 1 root root 101M Mar 19 17:00 initramfs-0-rescue-29b02705cf7844c0a674657f64cac8f2.img
-rw-------. 1 root root  52M May 13 18:25 initramfs-6.2.14-200.fc37.x86_64.img
-rw-------. 1 root root  52M May 14 16:24 initramfs-6.2.15-200.fc37.x86_64.img
drwxr-xr-x. 3 root root 4.0K Mar 19 16:59 loader
drwx------. 2 root root  16K Mar 19 16:54 lost+found
lrwxrwxrwx. 1 root root   46 May 13 18:25 symvers-6.2.14-200.fc37.x86_64.gz -> /lib/modules/6.2.14-200.fc37.x86_64/symvers.gz
lrwxrwxrwx. 1 root root   46 May 14 16:23 symvers-6.2.15-200.fc37.x86_64.gz -> /lib/modules/6.2.15-200.fc37.x86_64/symvers.gz
-rw-------. 1 root root 8.1M Apr 30 21:32
-rw-------. 1 root root 8.1M May 11 12:14
drwxr-xr-x. 9 root root 4.0K Apr 22 11:59 timeshift
-rwxr-xr-x. 1 root root  13M Mar 19 16:59 vmlinuz-0-rescue-29b02705cf7844c0a674657f64cac8f2
-rwxr-xr-x. 1 root root  14M Apr 30 21:32 vmlinuz-6.2.14-200.fc37.x86_64
-rw-r--r--. 1 root root  161 Apr 30 21:29 .vmlinuz-6.2.14-200.fc37.x86_64.hmac
-rwxr-xr-x. 1 root root  14M May 11 12:14 vmlinuz-6.2.15-200.fc37.x86_64
-rw-r--r--. 1 root root  161 May 11 12:12 .vmlinuz-6.2.15-200.fc37.x86_64.hmac

Thanks in advance for the help in this matter

Why, timeshift is nothing bad. It makes snapshots of your system.

Description  : Timeshift for Linux is an application that provides functionality similar to
             : the System Restore feature in Windows and the Time Machine tool in Mac OS.
             : Timeshift protects your system by taking incremental snapshots of the file
             : system at regular intervals. These snapshots can be restored at a later date
             : to undo all changes to the system.
             : In RSYNC mode, snapshots are taken using rsync and hard-links. Common files
             : are shared between snapshots which saves disk space. Each snapshot is a full
             : system backup that can be browsed with a file manager.
             : In BTRFS mode, snapshots are taken using the in-built features of the BTRFS
             : filesystem. BTRFS snapshots are supported only on BTRFS systems having an
             : Ubuntu-type subvolume layout (with @ and @home subvolumes).

Bit if it makes them in your /boot folder it can be a problem because of the space.

Maybe the easiest way.

But maybe someone else has a idea how to fix.
Please show us lsblk -f so we do have a better picture how your installation is made.

1 Like

It looks like you chose to save Timeshift’s snapshots in /boot.

That filled up the 1 GB quickly and snapshotting likely failed.

So, how about removing /boot/timeshift/snapshots, then updating, then setting up timeshift again, this time with a more appropriate snapshot destination?

I read timeshift places its snapshots in /timeshift of the backup device you select. You may have accidentally choosen your /boot partition as snapshot drive. Change that and delete /boot/timeshift.

1 Like

sudo dnf remove timeshift you can give it a try. Before you hit y you can check if there are more files deleted than timeshift it selves.

I do not believe that this will remove the folder timeshift in /boot. Mostly apps just remove the binaries and let the config/data on the system in case you install it again.

I propose to do as @augenauf said. Remove timeshift data from /boot

Instaed of using timeshift on your main system again, you could test it in a VM first. To see how it works and affects your system.

Here is my lsblk -f

NAME        FSTYPE FSVER LABEL                 UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
└─mmcblk0p1 vfat   FAT32 SDCARD                400A-80A8                                           
zram0                                                                                              [SWAP]
├─nvme0n1p1 vfat   FAT32                       6A48-0764                             581.4M     3% /boot/efi
├─nvme0n1p2 ext4   1.0                         60317848-5193-4534-a690-9d27b12d92d6   26.8M    90% /boot
└─nvme0n1p3 btrfs        fedora_localhost-live 488998a2-0048-43b9-9db2-164d65a14c40  147.5G    35% /home

Thank you for your help @augenauf and @ilikelinux

That solved the problem.

My recent install of the Timeshift app was the problem. I recall performing a quick review of the app. However, I don’t recall setting anything let alone snapshots in /boot. But it was set on the /boot partition.

Care does have to be taken to remove the snapshot folder contents. The biggest folders were /boot /bin and /usr. Once you figure out how much to delete at a given time. The cleanup job was relatively quick.

This post is resolved.

1 Like