Error EXT4-fs ext4_lookup:1855: inode comm updatedb: unexpected EA_INODE flag (structure needs cleaning)

I was reading my daily logs, like a good sysadmin, and I saw this in the journal, which I’ve never seen before.

Nov 15 05:04:34 <hostname> kernel: EXT4-fs error (device dm-3): ext4_lookup:1855: inode #8331004: comm updatedb: unexpected EA_INODE flag

It scared me, but, reading up on EA_INODE, it’s not obviously something I need to worry about, nor is it obvious what my system is trying to tell me. Does anyone understand what this could mean?

I could not find anyone reporting this in a few web searches.
But I agree with you that it is concerning sounding.

Have you run fsck on the file system to see of it can find any problems?

Right, me too. I tried pretty hard to find someone else reporting the same thing, but I didn’t find it.

I haven’t. That’s a good idea. I can try that. More soon…

You might want to find out what file this inode corresponds to.
It seems that this is the most general way to find file for a inode.

find /path/to/mountpoint -inum <inode number>

The find may return more then one answer if hardlinks are involved.
Or it may find none if the file has been deleted.

Give the filename you would be able to decide if its a critical or not file.

Aha. find found the inode in lost+found/ . So, whatever it is, the data was already not where it was supposed to be. Suppose that means it’s not important, since I haven’t noticed it missing. Although, that’s not guaranteed. file cannot read the data, though: cannot open #8331004 (structure needs cleaning). Sounds like your suggestion is the best plan. I guess I could try to back up the whole FS, but I actually don’t think I have…oh, well, I think I do actually have something big enough to back it up. But, I don’t think I will. We’ll just see what fsck says.

Dang. That didn’t help. fsck didn’t find anything wrong. I tried -f -D and -E fragcheck, too, and they also didn’t fix anything. However, when I tried -E discard, it did report that that FS had errors, but I think that it says that whenever this option is used, because all previous runs didn’t say that. But, discard did generate the same error about that particular inode and “structure needs cleaning”. I forgot to make notes while I was in boot singe mode, so I might not be remembering everything correct.

The upshot is that I still have that error about “structure needs cleaning” when I try to read, rm, or find that file.