Erratic audio in Fedora 35

I’ve very recently upgraded from F34 to F35 and I now have audio playback problems. It’s not the (well known) problem of wireplumber not starting - it’s symptom is intermittent playback.

I use amarok for music/podcasts and when playing a track, it all starts off normally. But if I skip 10 seconds forward (right arrow), sometimes once, sometimes twice, the audio stops (but amarok continues playing). Similarly If I move the cursor in the track with the mouse, similar things happen. Audio can be restored by randomly moving the cursor either with the arrow keys or with the mouse. Also once started, the track usually plays properly, but audio has occasionally stopped during play without me interfering.

This problem occurs with amarok - I tried exaile and that did the same. Other programs (like firefox, audacity, smplayer) seem to be absolutely fine. The only common factor in amarok and exaile that I can think of that might be relevant is that they both have gstreamer backends.

I’m really not sure about how to start debugging this. Any words of wisdom would be very welcome. In particular, I’d be really interested to know whether others have used amarok satisfactorily on F35.

Many thanks - much appreciated

Replying to my own post… The problem seems to have gone away now that I have installed the wireplumber 0.4.5-3 update that appeared the other day. Hurrah!

Best wishes

1 Like

I have exactly the same problem, but with some choppiness too when playing certain files in programs using gstreamer (rhythmbox, quod libet) etc. Unfortunately the latest wireplumber hasn’t solved it.

As an aside, I have one of those dreaded soundcards where you had to set realtime-scheduling = no in a conf file for pulseaudio. What is the equivalent option in pipewire/wireplumber/pipewire-pulse? I suspect this could solve the problem.

Problem is back again! The latest batch of Fedora updates installed this morning (29 Nov) which, I recall, included a batch of audio updates has broken gstreamer for me. Sigh!

I am having the same problem. See my thread here:

It’s so frustrating. I’ve been running Fedora since version 21, but this could be the deal breaker for me.

1 Like