EPSON WF-3730 log message says print job sucessful but no output on printer

I am having problems getting my EPSON WF-3730 to print from my computer.

After I print from an email or a libre office write document messages appear in the log indicating that the print job has worked but nothing prints.
For the print from Seamonkey email the log message is:-
REQUEST localhost - - “POST printers EPSON_WF_3730_Series HTTP/1.1” 200 31085 Print-Job successful-ok

For the print from Libre-Office Writer the log message is:-
REQUEST localhost - - “POST printers EPSON_WF_3730_Series HTTP/1.1” 200 18948 Send-Document successful-ok

I need to know whether the problem is with the particular printer in which case I will get it exchanged or fixed under warranty which expires in a month or whether it is in Linux or CUPS or the EPSON drivers that run under CUPS in which case I

Has anyone seen similar problems with an EPSON printer that are caused by LINUX or CUPS or the EPSON support files for CUPS.

Try the printer on a different machine. If it works there then the issue is likely software.
If it doesn’t work on another machine then it is likely the printer.

Today my sister in law brought her ipad and tried to print to my
printer. Result inconclusive, the print button on the iPad’s print
request form was greyed out. This may indicate the printer not
working or may indicate that the printer has not been activated from
the iPad. With Linux the printer rejects jobs which is a different
symptom unless one has first gone into setup/printers and unlocked
the printer and explicitly starteed it. Neither my sister in law nor I are experts wiith the details of
printing from the iPad. Because of the COVID19 restrictions she
could not stay to experiment.
I am reading up on tcpdump at the moment and when up to speed
with it will examine communication between my laptop and the printer
to see if the laptop sends anything to the printer . Also EPSON has
some cloud based facilities that can be used to print to a printer
from anywhere in the world. i will investigate these.
thankyou for your thoughts, regards TheEvilone.

If I understand correctly, when using linux you go into the setup/printers panel and then unlock and start the printer after which you are able to print.

If that is the case, there likely is an issue with communication to the printer that causes it to be “stopped” by the print manager when an error occurs.

I had a similar issue some time back when I first started using a wireless printer at home.
At that time I was allowing the wifi hot spot to assign an automatic IP address to the printer and what I found was that when the printer went to sleep for power saving it would not wake up with trying to print to it. I had to manually restart the printer then it worked.

Now I use a fixed IP address assigned from my router (DHCP reserved) and usually don’t have any issues with the printer. Sometimes the issue still occurs where I have to restart the printer, but that seems to be when I have not sent anything to the printer for 2 or 3 weeks so it really has not communicated for a long time.

Maybe you can try a restart of the printer to see if that helps.
Also, since I use an HP printer I have the HP graphical tool to restart the printer when it actually is stopped by the system.

Thankyou for your suggestions computersavvy.

The symptom when the printer is not started under Linux is different,Ffrom the application from which one is printing the message “Printer is rejecting jobs” is returned. After unlocking and activating printer under Linux one no longer gets the “rejecting jobs” message but jobs vanish from the printer queue and the messages about successful job appear in the log file. Nothing appears on printer though

Regards, The Evil One.

I have been forgetting to ask the basic trouble-shooting questions.

Have you tried the USB port so that you are direct connected and see if it will print that way?
Have you tried the wired network connection? Or have you been trying wireless only?
Have you verified the IP address & netmask settings at the printer?
Have you checked at the router/modem to verify the printer is connected, has an assigned address and that it is static?

If you do this you can create a new printer config for each connection type for testing purposes.
Then it will be easier to identify if the issue is hardware, software or network related.

My biggest problem with wireless printing has always been network related, especially with DHCP address assignment. I found that allowing the IP to be assigned as dynamic often caused the most problem. Each router doing DHCP has a range of addresses that are not part of the DHCP pool and assigning one of the static/open addresses to the printer is the easiest way to prevent the DHCP server from changing it’s address so when you configure it under linux the address never changes. A changing address can have the effect you have described.
A network printer configured under linux is usually configured with a fixed IP address and if it it not at that address it will never print.

Good suggestions Jefferey.

The printer is connected to the router using an ethernet port.

Communication with the printer is possible as I can access its setting via my browser and my sister in law could see the ink capacity readings from her ipad.

The DHCP addresses of devices on the networkdon’t seem to change much,as allmost all devices are powered on most of the time. They include my mother in law’s iPad & iPhone and my laptop.All these use wireless connection, the printer is the only one using a wired connection.

I would try my mother in law’s ipad except it is set to use Chinese language and I am not confident enough to try switching it between Chinese to English and back,

Regards The Evil One.

Furthermore I have asked my sister in law to search for an enable/disable option for printers accessed from her ipad analogous to the sTOP/START option in Linux Setup/Printers/. It may exist and may have been STOPPED and that may have explaiined the reason that the print button was greyed out.

I have entered the following tcpdump command:-
tcpdump -i wlo1 -n -nn -# -p host

then printed an email and observed an exchange of packets between (my laptop) and (my EPSON WF-3730) and captured 115 packets before terminating tcpdump with CTRL-C. This verified that data was going to the printer. However nothing printed so it is clear that the printer is at fault.

The next thing to do is to contact epson to find out whether there is any printer setting that can cause jobs to be buffered in the printer but not printed or can surpress printing completely.

At least you have narrowed it down.
Hope you find the answer soon

Due to COVID19 Epson Australia’s phone help line is closed and i cannot find a way to send a question via the web, there is a messaging interface that does not seem to work with Seamonkey which is my preferred browser.

EPSON has a cloud based service called EPSON CONNECT. One can register a printer and then that printer acquires an email address a_long_random_string+of_letters_and_numbers One can send an email with an attached pdf or microsoft office document to this address and both the email and the attached document will print.

On 2020-04-07 I sent an email with an attached .pdf form that I wanted printed to my printer’s email address and both the email and the .pdf printed. This means the printer is working over the network and the problem is with the LINUX printer support or there is an intermittent error that went away after the printer was powered on permanently for a couple of days as it was before I emailed the print request. I have still one last test to do. That is see if I can now print from my laptop. If I can the fault in intermittent if I cant the problem is o the Linux side.