Epson L360 Inkjet Printer

Hi all. I have Epson L360 Inkjet/Deskjet printer. I have not been able to make it work in Fedora 31. I downloaded Printer Utility from Epson website: SPT_C11CE55501 | Epson L360 | L Series | Epson Malaysia

And then run dnf install:

sudo dnf install epson-printer-utility-1.0.2-1lsb3.2.x86_64.rpm

But when I run “Test Page” the Test Print page did not print correctly.

Please advise

Are your sure this is an official site?  .my domain?
(btw, .my stands for Malaysia, not for a British word “my”).

Try this: – better interface, newer drivers.

dnf install lsb

There is also a scanner driver.

Yes. I am in Malaysia and it was official Epson Malaysia website. However I saw from your screenshot the link you provided had newer drivers. I will try the driver listed in that link

I downloaded drivers from link: and try to install
dnf install epson-printer-utility
but did not work.

I then tried to use Drivers available in Fedora: Epson L310-CUPS+ Gutenprint v.5.3.3. Tried to print Test Page and succeeded. I will try to print other documents.