Enabling amdgpu on Fedora Kinoite

Hi! I’m having trouble enabling amdgpu kernel driver on my pc. My GPU (R9 280) ships with radeon driver by default but that driver doesn’t support vulkan.

I’ve succesfully enabled amdgpu on Fedora 35 Workstation but Kinoite is giving me trouble. I’ve followed this guide thespecter.net on Workstation and just adding kernel parameters
radeon.si_support=0 amdgpu.si_support=1 and updating grub with * sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg* does the trick. But not on Kinoite. I’ve tried layering packages mentioned in the link with rpm-ostree install command but 64-bit packages are already installed. 32-bit packages can be layered in but it doesn’t effect on the result.

Found this post: Fedora forums and tried bloxking kernel module creating radeon.conf file (has line blacklist radeon) on /etc/modprobe.d folder. Then updated initramfs with *
dracut --regenerate-all --force* → reboot. And still it uses radeon instead of amdgpu.

Any additional tips/tricks or something I did wrong?

May want to try using

sudo rpm-ostree kargs

to add the kernel parameters.

Yes, that solved the issue. Thanks a lot :slight_smile:

1 Like