Enable natural scrolling for external touchpad

Since most devices nowadays use “natural scrolling”, which means a sense of kind-a manipulating the underlying surface/paper, instead of the screen in between, I enabled it for my laptop as well. That’s easy to do in Gnome’s system settings.

Unfortunately, Gnome’s settings don’t seem to apply for external devices. So when I use my keyboard with integrated touchpad, scrolling is inverse, which is very confusing.

So I’d appreciate your help to
enable “natural scroll” for my external keyboard w/ touchpad in Gnome?

I figured out that Wayland uses libinput, but that’s only defaults before the desktop applies it’s settings. With gsettings you will find the Gnome settings which only apply to the internal touchpad.


1 Like