Emergeny mode, computer crashed and wont boot

Boot up error?
When bootimg up my pc now it goes to “Emergency” mode and i can not do anything.
Please help.

In the middle of what i have allways used the computer it suddenly stopped, audio played for few seconds vut screen was frozen and as the audio stopped all went dark.
After i did a restart it loaded up with no problem started up steam and firefox, loaded firne and looked at my temps, all were fine (under 45c) and then again black screen and no responce.
I tried alt+control+F2 and i saw some text(in image).
What do i need to to, can anyone help?

1 Like

I suggest you boot to the live media (install media) and run fsck on all the file systems on that drive. The error is on nvme0n1p4 but when running fsck on one partition I also run it on all partitions on that drive since it is already idle and nothing mounted. This can and often does happen when something has corrupted a file system.

I had similar happen recently on /boot and a quick fsck (with the file system un-mounted) fixed it for me.

1 Like

Due to health issues(spinal and back nerve damage) and i have not been able do try to repair untill now, also past 3 years (same health issue) have only be able to do minimal linux code/system things as i have some majorly strong meds and unable to think that deep/mutch anymore so i might need some more noobish examples if possible, thanks(also on mobile).

Anyway i did a usb thumb with last see table fedora os (34) bood but at had more problems and did not know should i continue with the fsck.ext4 -pf /dev/nvme0n1

nvme0n1 is the drive.
The partitions would be named
nvme0n1p1, nvme0n1p2, etc.
If you know the file system on each partition then yes, run fsck on each partition on that drive.
You can find out the partition type with running
sudo fdisk -l
then as appropriate run fsck on each partition. It appears you may be using LVM, in which case the devices will be named /dev/mapper/live-rw or similar for the logical volumes (LVs) with file systems

On mine I have an ext4 partition at /boot which is on nvme0n1p5 so I would run
sudo fsck.ext4 -pf /dev/nvme0n1p5
or for the efi partition I would use
sudo fsck.vfat -pf /dev/nvme0n1p1

Note that if your file system is btrfs then fsck is not the correct tool.

The actual error reported is the [ TIME ] entry there on /dev/mapper/live-rw which is the device I would run fsck on first. It appears to be the root (/) file system