Embedded Videos in firefox not playing

Recently i have been having issues with embedded media in firefox mainly videos. The issue arose a few days ago, i had updated all my packages, rebooted and then they stopped working. Anyone else experiencing this or know how to fix it?

I had the same experience also a few days ago, just as when I wanted to watch a video of Fedora server administration :slight_smile: As a result I installed Google Chrome and watched the video with that. By now, this problem with Firefox seems to have gone, though.
This is the version of my OS and Firefox:
Fedora Linux 36 (Workstation Edition) x86_64
Firefox: 104.0.1 (64-bit)


I’m on the same version of Firefox, and Fedora, perhaps its some other underlying issue.

Is it flatpak or rpm version of Firefox? If it is the rpm version of Firefox, do you have ffmpeg-libs package from rpmfusion repository installed?

RPM version. I have ffmpeg installed, and ffmpeg-libs is not a package available ffmpeg-free is the one available and installed

ffmpeg-free is the one distributed from the fedora repos and does not have the codecs for some of the restricted formats.
I have these.

$ dnf list installed ffmpeg*
Installed Packages
ffmpeg.x86_64                                5.0.1-3.fc36                                          @rpmfusion-free        
ffmpeg-libs.x86_64                           5.0.1-3.fc36                                          @rpmfusion-free        
ffmpegthumbnailer.x86_64                     2.2.3-0.2.20210902gitd92e191.fc36                     @rpmfusion-free        
ffmpegthumbs.x86_64                          22.04.3-1.fc36                                        @rpmfusion-free-updates

The thumbnailer and thumbs packages are not required, but the others are.


I could have sworn I had rpmfusion installed on this system. Guess I was wrong, I was able to get ffmpeg-libs and embedded media works again. thank you.


hi there, I encountered that same issue, however, I already have libswresample-free installed (required by signal-desktop and vlc) and it seems to conflict with ffmpeg-libs.

Is there any way to solve this issue without ffmpeg-libs or to solve the conflict?

EDIT: I tried to use the mozilla-openh264 package by following these instructions but videos are still not playing.

Packages from other 3rd party repos (as it seems signal-desktop and libswresample-free are) may conflict with packages from fedora-centric repos such as rpmfusion. It is fairly simple to remove the conflicting packages but it is up to you to decide which is more important to your needs.

@computersavvy Well, that’s the thing, both having Signal/VLC and videos in Firefox are kind of a requirement for me (I mean, these are really basic things that work out of the box in all other distros I’ve tried), so the question is more “how can I bypass this conflict”, or “did I miss something with mozilla-openh264, shouldn’t it work”?

From what I understood, it seems that the non-free ffmpeg should not be necessary for videos in Firefox, but in practice the plugin just does not seem to work on my computer.

The ffmpeg and ffmpeg-libs packages are required for all codecs that are not 100% unencumbered with licensing, copywrite, or patents. Fedora only supports the ones that are unencumbered.

Firefox, from whatever source, uses ffmpeg and if you have the ffmpeg-free package from fedora it limits what firefox is able to process.

Let’s try this another way: is there a non-free libswresample that I could install to replace libswresample-free and that I could use with ffmpeg-libs, any way in which I could satisfy the Signal/VLC requirements while installing the non-free ffmpeg?

EDIT: I gues if I install Signal and VLC from flatpak that would work, right?

EDIT 2: OK, I removed the RPM libswresample, (which removed signal-desktop, and VLC), installed ffmpeg, then reinstalled Signal/VLC and everything works fine now.
I guess they use libswresample if only ffmpeg-free is installed but somehow know that it’s not needed with the full ffmpeg with non-free additions.

(I am limited to 3 replies per thread as a new user, hence the edit instead of a reply to @computersavvy)

I have no clue. I use vlc installed as rpm, and do not use signal. Vlc works with all videos I have.

# dnf list installed vlc
Installed Packages
vlc.x86_64                                              1:                                               @rpmfusion-free-updates

wow i experienced this too.
i have tried several ways above but not worked for me.

but luckily i solved this by installing chrome browser from their website . but yap this chrome is owned by google but this can plays embedded videos flawlessly