EasyEffects and surround sound (5.1)

Hi, I’am using F35c with 5.1 surround sound on HDMI.

Everything with the sound is fine (I can hear sound from all speakers) until I run EasyEffects 6.1.5 (formerly PulseEffects).
Equalizer plugin works, but the sound becomes regular stereo (I can only hear sound from the two front speakers).

My goal is to use EasyEffects and 5.1 surround sound.

I would appreciate it if you could tell me if this is a limitation of EasyEffects, or if I missed something in the configuration?

I wonder if this is related to the Wireplumber/EasyEffects output issue.

One suggested solution was to run sudo dnf swap wireplumber pipewire-media-session to revert back to the “old way.”

I also wonder if this may be related to running on wayland vs xorg. An easy way to check that would be to log out, then log back in while selecting ‘gnome on xorg’ from the gear at the bottom right of the login screen where you enter your password. If it does not change things you can switch back to wayland the same way.

Just out of curiosity, what benefits does EasyEffects give that make it necessary to use? I have never tried it.

Thank you @computersavvy for your reply.

I use Fedora with the Cinnamon desktop environment. I don’t see during login the “gnome on xorg” option you write about. I only have the “Cinnamon” and “Cinnamon (software rendering)” options.
It looks like I am on “XOrg” - according to the system information my configuration is: “Display: x11 server: XOrg 1.20.14”

EasyEffects lets you play with sound. You can adjust the speakers or the microphone.
This may not be necessary, but it gives you additional options.
More info at:

I wanted to use the equalizer, but every time I run it, the sound changes from surround to stereo.

Thank you @bryanmoore for the suggestion. I will check it out.

Before I run: sudo dnf swap wireplumber pipewire-media-session, I would like to know how to return to the current state.
Will the sudo dnf swap pipewire-media-session wireplumber command restore the previous configuration?

How can I check what the current configuration is? Is there a command that will allow me to check this?

I believe so, but as I haven’t done this I’m not completely sure; perhaps someone with more know-how can comment on the “reverse” command?

As I understand it, if you’re running F35 you’re running wireplumber.

What do you mean by “current configuration?”

By checking current configuration I meant to check what pipewire or wireplumber is currently running. So that I could make sure that the second, “reverse” command, worked as assumed.

If you’re currently running wireplumber, journalctl -xe | grep wireplumber should return a few lines, but journalctl -xe | grep pipewire-media-session will yield nothing.

Hi, I think before you take further tweak, first you should make sure that you have true surround file to test and not stereo audio file. To check if the file are true surround:

[testcase@fedora]$ aplay -D pipewire sample-sound-file.wav
Playing WAVE 'sample-sound-file.wav' : Signed 24 bit Little Endian in 3bytes, Rate 48000 Hz, Channels 6

For surround 5.1, it will have 6 channels.

After making sure you are using the right file, you can play it with your current media player and open also easyeffects. Then use qjackctl > click Graph to check if easyeffects it self support sorround file. If easy effect from Graph qjackctl only showing two channels, than you need to map it manually by dragging a line to your audio sink (make it double for example FR to FR and RR, FL to FL and RR, FL-FR to FC and LFE).

The other scenario if easyeffects support surround file, it will have 6 channel on Graph (FR FL RR RL LFE FC) and it will mapped automatically. If this the case, then your file you have now (you mention on above post) must be stereo file and you need to map it manually from audio player to easyeffects then from easyeffects to your audio sink.

I believe there also a way to up mixing stereo file to more than 2 channels with pipewire, but it’s confusing. It’s lot easier to use qjackctl.

You can download surround file from here.

1 Like

I tried both and got nothing:

Prefixing a command with “sudo” does not change anything.

Hi @oprizal , I used qjackctl and got this graph when playing 5.1 audio file:

When I run EasyEffects (and play the same 5.1 audio file), it looks like this:

Looks very weird.

Hi, for me look like easyeffects only support stereo. You could drag line from easyeffects_filter :

“output FL” to “playback RL” and “playback FC” of Built-in Audio Cyfrowe przest…
“output FR” to “playback RR” and “playback FC” of Built-in Audio Cyfrowe przest…

Yes, there a duplicat line to “playback FC”. For “playbcak LFE”, just leave it empty since it for lower frequencies. I’m afraid if you force to add a line to it, it will broke your subwoofer speaker (it possible, but just for precaution).

Or just don’t use easyeffects at all for now. :sweat_smile:

1 Like

It appears that EasyEffects supports stereo and only stereo. See

1 Like

Odd… I wish I had more to say about that, but we’ve reached the end of my troubleshooting abilities on this.

Thank you for your help

@rebi7, please note that a workaround has been posted at mutichannel (routing)? · Issue #1126 · wwmm/easyeffects · GitHub – works well for me on Fedora 36 with EasyEffects, getting 5.1 surround sound; stable across several reboots.

1 Like