Dummy output and no input audio

I installed fedora37 in my new laptop xiaomi book air 13. I found there’s no sound and in the audio settings my output device is “Dummy output” and my input device is greyed out. I searched for the issue in the internet and tried countless work around but only one method can save the audio output, presented in this link as #2 fix. I did as the article says and the output comes back. However my input device is still greyed out. Then I tried this method described in archwiki. And after I rebooted, there is built-audio in input device as well as output device. But they neither work. When you click test button, there is no speaker to choose (before i tried the work around in archwiki, there are a front left speaker and a front right speaker to choose). And there are more built-in audio hdmi output devices. What should I do now.

Welcome to ask.fedora @ykpcx

Did you give a try to a live iso to find out if it works there ?

If not please check on the link below how it looks like about the compatibility of the Kernel you use.


Can you post:
lspci -nnk | grep -i audio -A2


1 Like

(post deleted by author)

thx for your reply, here it is.

audio device doesn’t work in fedora37 livecd.

I got this from dmesg

[    9.465213] sof-audio-pci-intel-tgl 0000:00:1f.3: Direct firmware load for intel/sof-tplg/sof-adl-rt711-2ch.tplg failed with error -2
[    9.465222] sof-audio-pci-intel-tgl 0000:00:1f.3: error: tplg request firmware intel/sof-tplg/sof-adl-rt711-2ch.tplg failed err: -2
[    9.465224] sof-audio-pci-intel-tgl 0000:00:1f.3: you may need to download the firmware from https://github.com/thesofproject/sof-bin/
[    9.465226] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed to load DSP topology -2
[    9.465228] sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_component_probe on 0000:00:1f.3: -2
[    9.465241] sof_sdw sof_sdw: ASoC: failed to instantiate card -2
[    9.465377] sof_sdw sof_sdw: snd_soc_register_card failed -2
[    9.465396] sof_sdw: probe of sof_sdw failed with error -2
[    9.524244] hid-sensor-hub 001F:8087:0AC2.0003: hid_field_extract() called with n (192) > 32! (kworker/2:0)
[   10.957933] rfkill: input handler disabled
[   11.764330] soundwire_intel soundwire_intel.link.0: Clock stop failed -110
[   11.764338] soundwire_intel soundwire_intel.link.0: cannot enable clock stop on suspend

And I tried installing the latest sof-bin from GitHub - thesofproject/sof: Sound Open Firmware , still got the same dmesg. Note I didn’t add options snd-hda-intel dmic_detect=0 or options snd-intel-dspcfg dsp_driver=1 when I got these dmesg. If I add one of them, the speaker works but the mic didn’t.

Can you check sudo dnf list installed alsa*firmware

and see if alsa-sof-firmware is installed.

If it is not can you install it.


it was already installed

The issue is solved by the maintainer of sof-project, here’s the github link.