Dual Booting with WIndows 10

Hi, I am pretty new to Linux and I am planning to dual boot Fedora with Windows 10. But before doing anything I have a few doubts. I’m hoping someone can help me with them.

I have Windows(UEFI) installed on an SSD and I am planning to install Fedora on my HDD. Are the procedures same when both OS are on different drives ?
(I don’t seem to have any raid config setup)

I prefer kde desktop environment. I’m hoping the install process is same for KDE as it is for the default. Isn’t it ?

In the partitioning section, should I select automatic or is manual partitioning mandatory for dual boot ?

Also I’ve read that it is not advised to go with the latest version of Fedora as it can be unstable so opt for the previous version. Is this true ?

I tried to install other Linux distros but my laptop only boots into Windows and has no option to select the Linux distros in the boot manager. That’s why I’m thinking about giving Fedora a shot since it supports secure boot. So my question is does Fedora automatically setup grub or do we have to manually set it up like in Pop OS ?


Hey and welcome @krypto37
Nice to see you in our Fedora community! :slight_smile:

Yes, it is!

No, this isn’t. Fedora 34 and its spins are pretty much tested and reliable for daily work. For sure we can’t expect all is working fine for all users! In this case bugs can be reported on bugzilla

I can speak from my experience that I have 2 SSDs. One is running Win10 and the other F34. On the boot process I can choose which one I want to start.

I hope all your questions and understandable doubts has been solved.
If not - just ask further questions :wink:



1 Like

Thank you for clearing those doubts I had. I still have these questions in my mind. I hope it’s not much of a trouble.

Does the updates for all spins of Fedora (say KDE) release at the same time as default version or do I have to wait ?

Also, about dual booting, should I choose automatic or manual partitioning ?

I think what I understand is that Fedora automatically sets up grub. If some problem arises like if I’m unable to choose which OS to boot to, is there any guide to resolve such issues ?

1 Like

You’re welcome :slight_smile:

The updates for all spins of Fedora will be almost at the same time. So, you don’t have to wait.

Actually automatic partitioning should work.

In case you may have issues this kind of bootmanager will solve your problem:




1 Like

I’ll try installing it and tell you how it goes.

1 Like

That’s cool! :wink:

Hi, I finally installed Fedora.

But there seems to be a problem. There is no audio output. In the audio settings, it can be seen that the media is playing (the bars changing with change in sound level), but there is no output from the speakers. I referred some other threads, but the solution does not seem to work for me.

Hey @krypto37

Are u using GNOME?

Have you looked in the Fedora WIKI for “Common Bugs” ?

Also sound for the latest versions have moved to an audo package interface named pipewire. Troubleshooting and configuration file edits for alsa don’t work because alsa is not turned on by default.

My experience was after moving a couple of sliders and clicking a few checkboxes, it started working. I Have no idea what actually caused the speakers to start working… :frowning:

Good Luck

1 Like

Thank you for answering. I reinstalled Fedora and that solved the problem. So far, loving Fedora!

I installed the KDE spin.
Thanks for helping out earlier. I did choose automatic partitioning like you said and it worked.

During my first attempt, grub didn’t show up so I followed the solution in this thread.

There seems to be a similar problem(I’m not entirely sure this is my problem, only a guess) addressed here and another one here.

But those solutions didn’t work for me. So I did a reinstall, but this time, I did not run the commands in the thread linked first. And it worked just fine.


1 Like

Thank you for answering. I am not sure what exactly is the cause of the problem in my case. I tried following the instructions in other threads referring to a similar problem but none worked for me. So I reinstalled Fedora and now the sound just works fine.


Hey @krypto37

I am really glad that this solution you have found for yourself worked finally.

If you should have any further questons, don’t hesitate asking in our forum! :slight_smile:

Have a nice weekend!


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.