Dropbox client sign in opens text file

Hello, I’m facing a weird behavior when, after installing nautilus-dropbox client, I try to sign in (clicking the icon in the bar)

When I click the sign in button instead of loading - I think - a webpage KWrite gets opened and the supposed page content is displayed

What could cause this behavior?

packages installed are:
nautilus-dropbox x86_64 1:2019.02.14-2.fc29 rpmfusion-nonfree-updates 26 k
Installing dependencies:
dropbox noarch 1:2019.02.14-2.fc29 rpmfusion-nonfree-updates 76 k

1 Like

Hi @leggy, welcome to Fedora! Please take a look at the introductory posts in the #start-here category if you’ve not had a chance.

It seems the “default application” to open HTML files has been set to Kwrite in your system. Did you make this change perhaps, to edit HTML documents?

The simple solution is to reset this to the browser. Right click on an HTML file and in the settings, you should be able to select your browser as the default application.

1 Like

Hello @FranciscoD thanks for your reply.
Unfortunately this does not seem to be the reason. As per attached image default application is Firefox 7427681f9f6c25b7e7b7e73c177126dd00d7c7e1.png

The issue is weird because it happened also with other desktop application trying to interact with web pages.

I also have no idea of what information I could provide to help better understand the problem.

  Hi.  Try to create a new test-user, log in as this user, and test if the issue is still there..?  Maybe try to delete a Kwrite, then install it again?
  BTW:  Can you test somewhere a newer version of Fedora (30 or 31)?

1 Like

Hrm, so that depends on what Dropbox is using to open the link then.


xdg-open <some html file>

open it in Firefox? That’s the default xdg tool that figures out what type of file it is and picks an application accordingly. I know gnome uses gio open, but I don’t know if KDE has its own version of that.

In the meantime, testing with a new user would be very useful, as @vits95 suggested. That will at least tell us if this is a system issue or something specific to your user configuration.

Okay, I tried a couple of things.

@vits95 creating a new user and trying to sign in to dropbox correctly opens the webpage in firefox
I would add that the new user was using gnome while this user is using kde plasma

@FranciscoD xdg-open my html file opens it as text in KWrite

So, apparently, it is something related to my user configuration… would be awesome to have any clue about what it could be

EDIT: I tried to change desktop environment to GNOME and it opened it correctly in the browser. So now it seems to be a problem with Plasma. If any of you guys would have any suggestion on how to try to fix it with Plasma would be appreciated

EDIT: Apparently the on-launch webpage redirect goes fine but then dropbox client fails to launch properly, so it is a dead end with GNOME too, just in another way

What about

gio open <html file>

It’s a bit hard because we don’t know what dropbox is using…

Can you clarify what’s happening here? I’m using the dropbox client just fine. Although I think I got mine from the Dropbox website, and that pulls in nautilus-dropbox.

gio open <html file> does open firefox

Sorry, I wrote it terribly.
I meant that by running GNOME the sign in page opened fine in firefox and I was able to proceed. Then (always using GNOME) dropbox keeps failing to launch. Switching back to Plasma, since client authenticated successfully (while running GNOME), application seems to work properly.

Hope I made myself clear enough

  Is it works within a new-test-user session in Plasma, too?

1 Like

yes, it does. A new user configuration must have left some default setting which works


Ah, well it works now, so at least that’s sorted. If you want to figure out what’s going on, running dropbox in a terminal should show you errors etc. especially if it fails to launch:

1 Like

  It's sad that some programs "detach" themselves from terminal (at least Firefox).

I will in the case update this thread with some useful info from dropbox run by the command line.

In the meanwhile thank you really much guys, since we sorted out how to have the system working.

Since I’m new to this could please tell me what reply should I mark as solution?

1 Like

  I think:  Create a new post with a concise summary, then mark it as solution.

1 Like