Downgrading AMDVLK driver on Fedora 33?

Hi all,

I’m trying to figure out how to downgrade my amdvlk driver on Fedora 33 from the newest release (amdvlk-vulkan-driver-2.175-0.20210208.git3e7f94e.fc33.x86_64) to the previous release (amdvlk-vulkan-driver-2.174-0.20210129.gitcfbfe47.fc33.x86_64). I’ve had an issue that comes and goes over the past few months, and it seems to be related to updating my amdvlk driver before an update to DXVK is available for that new driver version. This is my third time experiencing this issue, and I’d like to find a way to reinstall the previous version.

The TL;DR for the problem I’m having is that any games that require Vulkan to run will spit out error messages saying something along the lines of “Vulkan is not available or is not installed on this system”, or “DXVK not found”, or something similar depending on the application I use (Lutris, Steam, Dolphin emulator, etc). This has been happening for the past 3 updates of amdvlk, and the only way it gets fixed is when an update rolls out for DXVK, which can take anywhere from a few days to a few weeks.

I was just waiting to update the amdvlk driver until the DXVK update rolled out, but mistakenly updated it too early. Problem is that I can’t seem to revert the update.

I used the “dnf history” command to see what the update ID of the update I want to revert is. It told me that the ID is 157. So I ran the following to try to revert it, but it returns the following error:

[stack@localhost ~]$ dnf history undo 157
Last metadata expiration check: 1:01:03 ago on Wed 17 Feb 2021 01:04:27 PM EST.
Undoing transaction 157, from Wed 17 Feb 2021 03:16:03 AM EST
    Upgrade  amdvlk-vulkan-driver-2.175-0.20210208.git3e7f94e.fc33.x86_64
    Upgraded amdvlk-vulkan-driver-2.174-0.20210129.gitcfbfe47.fc33.x86_64 @@System
No package amdvlk-vulkan-driver-2.174-0.20210129.gitcfbfe47.fc33.x86_64 available.
Error: no package matched

Looking online, I wasn’t able to find any information on how to actually do this other than through using dnf’s “undo” function.

Any help or ideas that anyone can offer regarding how to either fix this problem outright, how to downgrade amdvlk, or some other workaround you may know of, would be greatly appreciated!

System info:
OS: Fedora 33 Workstation
Kernel: 5.10.15-200.fc33.x86_64
Graphics card: RX 5700xt
Graphics driver: AMD Mesa driver 20.3.4

1 Like

You can use the --exclude=package option to dnf for packages you want to delay updating or to only update manually.

There also is a --downgrade option although I have never used it.

Man dnf for full details on both.

It’s a little troublesome, but should be possible.

You can get a specific version SPEC file here:
History for amdvlk/amdvlk.spec - tomkv/packaging-rpm · GitHub

And using that spec, create your own COPR repo:
Copr Buildsystem — COPR documentation

1 Like

Thanks for the suggestions!

I tried --downgrade with dnf, but it doesn’t seem to work, presumably because the older version of the amdvlk driver is no longer available in the repo.

And as for creating my own repo with COPR, I’ll look into. I’m fairly new to Fedora and Linux as a whole though, and a lot of the stuff involved there seems to be over my head. I’ll play around with it and learn more about it though. I was curious how that stuff worked anyway, just never had the reason to look under the hood.

Thanks again!

1 Like