Double letters in search on Gnome (again)

I’m still facing the issue that was described here: Double letters in search on Gnome

I am getting double letter when typing in Gnome search. The first letter is double.
If I type “firefox” I get “ffirefox”. But this happens only occasionally, maybe just after the display goes idle and I log back again.
I’m using fedora 35.

Is it only me? Can anyone suggest a solution?

Hi, maybe your could try if this also happen with “Screen Keyboard”. Gnome Setting > Accessibility > Typing: Screen Keyboard.

If with screen keyboard is work fine, may be it’s your physical keyboard or connection or anything related with your hardware.

Hi Syaifur,
Thank you for your answer. I tried what you suggested, but the same result. double or sometimes 4 times the letter that I pressed :slightly_frowning_face:

Does making changes to settings → Accessibility [Typing] Repeat Keys make any difference?

Or Typing Assist and enabling bounce keys?

1 Like

registered to say i am having same issue. regardless the first character, it is always double typed

edit: fedora 36, gnome 42.4

Same problem here !

Can you all please create new users and see if the issue persists there?

I do not have this problem when creating a new user.

1 Like

So that indicates that this is somehow caused by a user configuration value. Could you please check all the accessibility settings to see if there’s anything enabled there. There are a few that change keyboard behaviour:

If you have any extensions installed, it’s also good to disable them all to see if that helps—if it does, you’d want to enable each extension one by one to see which one causes it.

Accessibility settings do not seem to have an impact.

I forgot to told you, but I already tried to disable extensions, and it does not change the behavior.

I had the same issue. I disabled all the extensions and rebooted the system. After rebooting not seeing the issue. Then I enabled extensions one at a time and do not see the issue anymore.

1 Like

I just tried it and, for the moment, it fixed the problem.

1 Like

Could it be that you are using the dash to dock extension? There is obviously a bug in the version 0.75. See here: Duplicate first key stroke on activities overview · Issue #1855 · micheleg/dash-to-dock · GitHub

There is also a workaround: In the extension settings under Appearance disable the option Show overview on startup.


I am using it, indeed !

1 Like

I was with the same problem at Fedora 37. For me, it happened after installing dash to dock extension. So, I did remove it, and the issue is gone.

1 Like

Make show overview on startup disabled really fixed the issue, thank you so much!