Does Fedora notify of updates? | Not in power saver mode!

I’ve noticed that no update notifications are displayed. When I go to Software>Updates it’s displayed that the system is up to date and when the last time was checked for updates, but when I click the circular arrow (Update), suddenly available updates appear.

I’ve found this website AutoUpdates - Fedora Project Wiki

Are AutoUpdates the same as update notifications?
Does Fedora notify of updates by default?

3 Likes

No, auto update means that Fedora installs the updates while restarting, downloading them in the background as they are available.

If you dislike this you can change it in the software app. On the Hamburger menu by preferences.

Notifications is a service you can control in the Settings > Notifications for every application.
If you want to see a popup for example, you can set this separately under Notifications > Software clicking on it.
If it is by default you will see when you open it. When it is blue (on) it is.

But doesn’t Gnome Software normally give notifications in the Panel ? Or is that disabled in Fedora?

You have to control it. It can change with every new version you install.

I’ve never adjusted notification settings, and I get notifications about updates if I’m patient.

I think what’s confusing (I found it confusing at first) is that you don’t get notified of every update immediately. So if you run “dnf check-update” or open GNOME Software on any given day, you’ll see updates available, but you won’t otherwise get a notification about them. You’ll get a notification about updates only once every couple of weeks unless there’s a “critical security update” (which does generate an immediate notification).

When I was trying to understand the logic, I found this discussion helpful: Review timing and content of software updates notifications (#947) · Issues · GNOME / gnome-software · GitLab

Edited to add: That page links to an even more insightful previous discussion: https://pagure.io/fedora-workstation/issue/107

1 Like

Basically you’ll get update notification from GNOME Software roughly every 14 days.

2 Likes

@kparal AFAIR I got an update notification, shortly after Fedora 38 Workstation was started for the first time. Meanwhile, an upgrade to Fedora 39 Workstation was done. Since the update notification, I didn’t get update notifications any more.

In Software=>Updates it says:

Up to date
Last checked: 2 weeks ago

Am I impatient or why do I get no update notifications any more? Is there possibly a problem with the settings for update notifications?

Well, if you don’t wait at least 1 more week, you’ll never know :slight_smile:

On top of seeing a notification when updates are ready, you should also “Install updates” checkbox in the poweroff/reboot menu (when they are ready).

Once you see “Last checked: 3 weeks ago” and no updates displayed, let us know and we can dig into it more.

1 Like

I didn’t understand this. What does this mean?

Screenshot from 2024-01-12 17-29-15

It should appear in the power off section (see picture), something like “Install Updates”.

@ilikelinux Still not sure, whether I understand this correctly. So, I should not only see a notification when updates are ready but also when I click on the WiFi/Volume/Battery button on the top right, then on the Power Off symbol, in the Power Off menu, there should be a checkbox something like ‘Install Updates’ that I should check?

The next box that appears when you click either “Restart” or “Power Off” is where that prompt appears – just above the “cancel” and “OK” buttons.
If there are updates waiting it should already be checked.

2 Likes

@computersavvy @ilikelinux @kparal This ‘Install Updates’ checkbox after clicking either ‘Restart’ or ‘Power Off’ was never displayed since I installed Fedora.

This is how it should look when new updates are downloaded and ready to be installed (once per 2 weeks by default):

image

2 Likes

Please provide output of this command:

gsettings list-recursively org.gnome.software

and this one:

sudo journalctl --since today -u packagekit.service

@kparal

gsettings list-recursively org.gnome.software
org.gnome.software allow-updates true
org.gnome.software check-timestamp int64 1703601432
org.gnome.software compatible-projects ['GNOME', 'KDE', 'XFCE']
org.gnome.software download-updates true
org.gnome.software download-updates-notify true
org.gnome.software enable-repos-dialog true
org.gnome.software external-appstream-system-wide false
org.gnome.software external-appstream-urls @as []
org.gnome.software filter-default-branch true
org.gnome.software first-run false
org.gnome.software flatpak-purge-timestamp int64 1705294593
org.gnome.software free-repos @as []
org.gnome.software free-repos-url ''
org.gnome.software install-bundles-system-wide true
org.gnome.software install-timestamp int64 1695732031
org.gnome.software installed-page-show-size true
org.gnome.software nonfree-software-uri 'https://de.wikipedia.org/wiki/Proprietäre_Software'
org.gnome.software official-repos ['anaconda', 'fedora', 'fedora-debuginfo', 'fedora-source', 'koji-override-0', 'koji-override-1', 'rawhide', 'rawhide-debuginfo', 'rawhide-source', 'updates', 'updates-debuginfo', 'updates-source', 'updates-testing', 'updates-testing-debuginfo', 'updates-testing-source', 'fedora-modular', 'fedora-modular-debuginfo', 'fedora-modular-source', 'rawhide-modular', 'rawhide-modular-debuginfo', 'rawhide-modular-source', 'fedora-cisco-openh264', 'fedora-cisco-openh264-debuginfo']
org.gnome.software packagekit-historical-updates-timestamp uint64 1703600397
org.gnome.software packaging-format-preference ['flatpak:fedora-testing', 'flatpak:fedora', 'rpm']
org.gnome.software prompt-for-nonfree true
org.gnome.software refresh-when-metered false
org.gnome.software required-repos ['fedora', 'updates']
org.gnome.software review-karma-required 0
org.gnome.software review-server 'https://odrs.gnome.org/1.0/reviews/api'
org.gnome.software screenshot-cache-age-maximum uint32 2592000
org.gnome.software security-timestamp int64 0
org.gnome.software show-nonfree-ui true
org.gnome.software show-only-free-apps false
org.gnome.software show-ratings false
org.gnome.software show-upgrade-prerelease false
org.gnome.software update-notification-timestamp int64 1695733721
org.gnome.software upgrade-notification-timestamp int64 0
org.gnome.software.auth account-id ''
sudo journalctl --since today -u packagekit.service
Jan 15 09:29:31 fedora systemd[1]: Starting packagekit.service - PackageKit Daemon...
Jan 15 09:29:31 fedora PackageKit[13012]: daemon start
Jan 15 09:29:32 fedora systemd[1]: Started packagekit.service - PackageKit Daemon.
Jan 15 09:30:32 fedora systemd[1]: Stopping packagekit.service - PackageKit Daemon...
Jan 15 09:30:33 fedora systemd[1]: packagekit.service: Deactivated successfully.
Jan 15 09:30:33 fedora systemd[1]: Stopped packagekit.service - PackageKit Daemon.
-- Boot bcbb67b12be7401ebefadec966b647b2 --
Jan 15 10:53:53 fedora systemd[1]: Starting packagekit.service - PackageKit Daemon...
Jan 15 10:53:53 fedora PackageKit[1602]: daemon start
Jan 15 10:53:53 fedora systemd[1]: Started packagekit.service - PackageKit Daemon.
Jan 15 10:54:20 fedora PackageKit[1602]: uid 1000 is trying to obtain org.freedesktop.packagekit.system-sources-refresh auth (only_trusted:0)
Jan 15 10:54:20 fedora PackageKit[1602]: uid 1000 obtained auth for org.freedesktop.packagekit.system-sources-refresh
Jan 15 10:54:21 fedora PackageKit[1602]: refresh-cache transaction /702_decbaadd from uid 1000 finished with success after 777ms
Jan 15 10:54:29 fedora PackageKit[1602]: resolve transaction /703_ecadcaab from uid 1000 finished with success after 5041ms
Jan 15 10:54:29 fedora PackageKit[1602]: resolve transaction /704_cbecebcd from uid 1000 finished with success after 11ms
Jan 15 10:54:34 fedora PackageKit[1602]: get-updates transaction /705_baececea from uid 1000 finished with success after 5023ms
Jan 15 10:54:35 fedora PackageKit[1602]: get-updates transaction /706_baedadcc from uid 1000 finished with success after 720ms
Jan 15 10:54:35 fedora PackageKit[1602]: resolve transaction /707_aeeedbcb from uid 1000 finished with success after 59ms
Jan 15 10:59:39 fedora PackageKit[1602]: daemon quit
Jan 15 10:59:39 fedora systemd[1]: packagekit.service: Deactivated successfully.
Jan 15 10:59:39 fedora systemd[1]: packagekit.service: Consumed 10.827s CPU time.

(Please use code blocks. I edited your post).

Looking at check-timestamp, it is indeed too old.

$ date -d '@1703601432'
Tue Dec 26 03:37:12 PM CET 2023

It should be checking regularly (probably every day).

What if you do:

pkcon refresh force
pkcon get-updates

Do you see available updates listed?

If you quit gnome-software and start it again:

gnome-software --quit
# now start gnome-software again from the menu

and wait a few minutes (but not click the arrow), does it display the new updates?
What about check-timestamp, did it change?

gsettings get org.gnome.software check-timestamp

And last idea, do you perhaps have your network connection marked as metered? Open GNOME Settings → Network, click the cog next to your connection, look at Metered connection checkbox. Gnome Software doesn’t check for updates automatically on metered connections.

1 Like

How do I use code blocks?

I executed both commands. After the second, a lot of packages are displayed.

I entered
gnome-software --quit
in the terminal. Nothing happened. There was no output and no menu was displayed. Only the command prompt appeared.

From which menu do I need to start gnome-software again now?

it’s the Preformatted Text button , Code is easily copied and pasted when you post it using this feature.

You would use the </> button on the toolbar to post text as preformatted, or you would use triple backquotes [ ``` ] on the lines preceding and following the pasted text. Either method would retain the formatting as seen on-screen for easier readability on our end.

Try editing the post that was mentioned and see what exactly was done when it was edited for you.