Does Fedora get ruined by mamba?

Yesterday I installed mamba in the conda base environment on my Fedora 37. After reboot it doesn’t boot to the login mask because a bunch of system manager modules are failing. I tried recovering things with live USB but when I logged into the system with chroot (to set the root passwort so that I could use the recovery mode) and tried to do something with dnf, I got the error “libdnf is not installed”. I don’t really understand how and why fedora and conda interact in the way they do, but I was suspecting my mamba installation to be responsible. Is this a known issue?

It should be possible to fix without using chroot:
Failed upgrade from F32 to F33 -- Kernel Panic - #3 by vgaetera

Thank you for the answer. Unfortunately I had no patience and already wiped the system and set it back up, so I can’t confirm if your advice would have helped. I was wondering if someone knows about mamba being an issue with fedora? Or how to use it safely?

I am also of course not certain if mamba really caused the issues I’m expiriencing

How and where did you install mamba? I have no problems with it on Fedora 36 on several systems.

Are you using Fedora 37 Workstation? Which mamba (mamba test runner on pypi or mamba package manager from conda-forge, mambaforge, or mini-forge or something else)?

Were other packages installed prior to your reboot?

There are many examples of boot failures where hardware drivers didn’t handle changes to the kernel. If a newer kernel is involved you should check for problem reports related to your specific hardware and kernel version.

1 Like

Yes I use Fedora 37 Workstation. As far as I know of, I only installed mamba and conda to the base env prior to the reboot. I used the conda-forge mamba version. I later read that this is not recommended and hence tried it the recommended way (mambaforge). This seems to work just fine.