Does F28 Silverblue support the GNOME Xorg session?


#1

Fought with my F27 Workstation to upgrade to F28. After I deal with the fact that I have to create a new user even though my old one definitely still exists, I manage to log into my desktop. I’m blind, so I need Orca, which means I can’t use Wayland because it has some issues interacting with Orca. I notice those issues are present, so I try logging back out and then in, but setting my session to GNOME Xorg.

Whenever I change my session and enter my correct credentials, I find myself back at the username prompt. If I leave the session alone, I get what I assume to be the Wayland session (assumed because I observe the Orca Wayland issues.) I assume that, because login doesn’t work and because I’m not given an “incorrect username or password” message, that the failure is happening as a result of me trying to change the session.

Is the Xorg session non-functional on F28? I’m very limited in what debugging I can do on this, since the only accessibility I have is post-login, and that is going to be severely limited if I’m stuck on Wayland. Were the necessary packages to run the Xorg session not layerd into the F28 ostree? If so, that makes Silverblue inaccessible, and I’ll have to switch back to the standard workstation.

Thanks for any help.


#2

I don’t know of any reports of X being completely broken in f28 but it’s possible. Is the system up to date? Can you post the output of rpm-ostree status here?


#3

Hmmm … I had some issues with an AMD GPU with F28 Silverblue: https://bugzilla.redhat.com/show_bug.cgi?id=1627913


#4

I have the same result if I choose Gnome Xorg session on F29 Silverblue. I also had the same issue about having to create a new user at upgrade (from F28 Silverblue), even though my current user is still there. I filed a bug on Pagure about the new user forced creation at upgrade (#49 I think). When I try to log into a Gnome Xorg session I get tossed back out to the log in screen.


#5

Wow, I’m finding all the bugs with this upgrade process. :slight_smile:

Thanks for confirming, and thanks for filing issue #49 as well. :slight_smile: Now
that I know where these should be filed, I’ll get my rpm-ostree version
later today or this weekend and file it.


#6

Hi,

Tried installing the xorg AMD GPU drivers as per your comments when you submitted the bug, and it still will not log into Gnome, although it tries to start the session. I should review the session logs for those attempts. Maybe post them if someone wants to see it.


#7

Some people get all the luck.


#8

You’ll need to edit /etc/gdm/custom.conf and enable debugging (the commented-out line near the bottom). Then use journalctl to dump the logs.

AMD GPUs are tricky beasts with recent Linux kernels - you may need to blacklist the kernel radeon module and add some parameters to the kernel command line.