Docs meeting agenda: 2023-01-25

Here’s the agenda for the meeting 2023-01-25T19:30:00Z in #fedora-meeting-1:

  • Announcements
  • Action item followup
    • pboy was to try the -b (build) & -p (preview) options of docsbuilder on mac
  • Tickets review: there are no tickets flagged for the meeting on GitLab
  • Gitlab guide needs an update (discussion - PR)
  • Quick docs update
  • Your topics here!
  • Open floor

I’ve pushed Quick Docs issue 111 up for a pull request. This is the update to the Installing From Source doc.

I probably won’t be able to attend these meetings again until mid-March (Q1 release docs time for me), but I’ll keep looking for Quick Docs issues or other issues to take.

My one request: If you’re working on an issue, please assign it to yourself so I know someone is working on it so I can move on to the next thing.

I can attend the first 30 min for other commitments today.

Minutes and full logs are available.


WhenIsGood results are up for the new meeting time, please vote for the final decision here (poll coming up)


  • hankuoffroad to create a poll with the 3 options for the meeting time
1 Like

Weekly Docs meeting is advertized
Each Wednesday, 18:30 UTC at #fedora-meeting-1
Currently, we gather at 19:30 UTC.
Which one should I display ‘AS-IS’?

The correct meeting time is 19:30 UTC.

Reading through the logs…

I’m completely ambivalent about the meeting times. The current time is going to be either 14:30 or 15:30 my time, meaning in the middle of my workday. So my attendance will be spotty at best. If the current time works for most folks, then my vote would be to keep it and I’ll just attend when I can.

I’m also envious that some of y’all are going to FOSDEM. I also want a new Vi mug… I had this on my desk for years, but can’t find where I put it: Vi mug. I actually used it as a reference for a while.

How does below statement in Pagure diverge from GitLab workflow?

This project does not support direct push to its git repo, all changes must be done via pull-requests from forks.

I’m stuck with the alerts popping up due to something unexpected or my mistake. Could you advise where I need to look and resolve this?

  1. In Pagure UI

Your task failed: Remote hook declined the push: Pull request required Denied push for ref ‘refs/heads/main’ for user ‘hankuoffroad’ All changes have been rejected

  1. Git push output

remote: All changes have been rejected
To ssh://
! [remote rejected] 521-find-install-apps → 521-find-install-apps (pre-receive
hook declined)
error: failed to push some refs to ‘ssh://

In order to be able to commit to QuickDocs you must be a member of either the group fedora-docs or quick-docs-committers. I’ve just added you to the group fedora-docs. I’ve just added you to the group fedora-docs, so you should now be able to commit to Quick Docs directly.

On GitLab, you must be a member of the group docs-admin, if I remember correctly.

In general, we want to use PR workflow, i.e. you commit to your fork and open a PR/MR. But we are not stringent in implementation, yet. And we have to check, based on experience, whether that is useful. E.g. if someone takes care of a specific repo, they maybe should be able to commit directly. And we have to make sure, that we care about any MR/PR in a short timeframe. But my notification doesn’t work completely.

1 Like

It works now in Pagure! Thanks.

Made a minor edit in the first section of partials for #180 Switching desktop environments .

Will give it a try for a few days with Pagure. For a complete rewrite, I’ll use PR.

Yes, I’m a member of the group docs-admin in GitLab. For now I’ll focus on Pagure to write up contributor guide.

I checked git config and the procedure in Pagure PR guide, but still welcome :slight_smile: by the following message in terminal

$ git push -u origin 521-find-install-apps
Enumerating objects: 17, done.
Counting objects: 100% (17/17), done.
Delta compression using up to 2 threads
Compressing objects: 100% (10/10), done.
Writing objects: 100% (12/12), 3.17 KiB | 1.59 MiB/s, done.
Total 12 (delta 8), reused 0 (delta 0), pack-reused 0
remote: Pull request required
remote: Denied push for ref ‘refs/heads/521-find-install-apps’ for user ‘hankuoffroad’
remote: All changes have been rejected
To ssh://
! [remote rejected] 521-find-install-apps → 521-find-install-apps (pre-receive hook declined)
error: failed to push some refs to ‘ssh://’

then I run

  1. First try: failed
    $ git push --dry-run
    fatal: The current branch 521-find-install-apps has no upstream branch.

$ git branch -vv #list all my branches that are tracking upstream branches
521-find-install-apps 5bd262f 521-apps-rewritten

  • main 30cc32c [origin/main: ahead 37] 521-app-install-guide

$ git branch -r #view git remotes
origin/HEAD → origin/main

  1. Second try: git push looks like okay
    $ git push --dry-run
    To ssh://
    a29b611…30cc32c main → main