Docker - moby - 404 = confusion

Greetings, I have installed Fedora Server 32 with Cockpit and looking forward to a wonderful experience using it as a host for several docker based applications.

However I cant install Docker. I get some references to Moby which seems old, the Docker project instructions for Fedora do not work.

sudo dnf install docker
Docker CE Stable - x86_64 540 B/s | 384 B 00:00
Errors during downloading metadata for repository ‘docker-ce-stable’:

  • Status code: 404 for (IP:
    Error: Failed to download metadata for repo ‘docker-ce-stable’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
    Ignoring repositories: docker-ce-stable
    Last metadata expiration check: 2:33:29 ago on Thu 06 Aug 2020 06:36:32 AM CEST.
    Dependencies resolved.
    Package Architecture Version Repository Size
    moby-engine x86_64 19.03.11-1.ce.git42e35e6.fc32 updates 51 M
    Installing dependencies:
    containerd x86_64 1.3.3-1.fc32 updates 32 M

Transaction Summary

Install 2 Packages

Total download size: 83 M
Installed size: 303 M
Is this ok [y/N]:



Doesn’t look live they’ve setup a repo for for fedora 32 yet:

I suggest contacting docker for and ETA.

Thanks Tom.


Unfortunately the official docker repo for fedora 32 is not ready yet, to know more about it and the reason of this problem, please follow this TOPIC:


1 Like

Got that, only hope Moby will follow the Docker releases… Akihiro say its only removed the brand name, but I really don’t get why, Docker is free…

1 Like

I suggest all of you to use Podman instead (


I’ve been quite happy using Podman and Buildah, but I’ve not been able to use them exclusively. For example:

I don’t see the point. Well, yes, a graphical interface to handle your docker images, but surely the Docker guys has that somewhere? I tried Podman for like 30 minutes and it was just adding to the confusion.

I went with Fedora Server > Docker > Apps for a reason, and that is to reduce the number of layers.

You can go:
Host > VM > Docker > Webapps but with this solution I have Host > Docker > Webapps

Now, I realize Podman isn’t a layer as such, but getting used to Docker and finding a solution made by Docker for Docker seems a more reasonable approach. If they have one, which I don’t know at this time.

hum, there are a few, and probably more: TOP 6 GUI tools for managing Docker environments | by KarthiKeyan Shanmugam | Medium

ehm, scrap that, seems only is up to date and active of those listed in the article.

Well, Cockpit can let you manager your Podman containers using a web interface just like Portainer does with Docker ones. You just must install the “podman-container” package (it’s like a “plugin” for Podman) and that’s all.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.